Skip to content

← Actionable
High, CVSS 8.8Exploited · CISA KEVamended

Electron affected by libvpx's heap buffer overflow in vp8 encoding

CVE-2023-5217GHSA-qqvq-6xgj-jw8g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 27.0.0-beta.8, 26.2.4, 25.8.4, 24.8.5, 22.3.25), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm electron

    Affected
    < 22.3.25>= 24.0.0, < 24.8.5>= 25.0.0, < 25.8.4>= 26.0.0, < 26.2.4>= 27.0.0-alpha.1, < 27.0.0-beta.8
    Fixed in
    26.2.4, 25.8.4, 27.0.0-beta.8, 24.8.5, 22.3.25

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-5217: 49.01% estimated exploitation activity in the next 30 days; percentile 98.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Heap buffer overflow in vp8 encoding in libvpx in Google Chrome prior to 117.0.5938.132 and libvpx 1.13.1 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qqvq-6xgj-jw8g

  2. Revision 2 · evidence added ·

    CISA KEV confirmed exploitation for CVE-2023-5217 (date added 2023-10-02). Customer workflow unchanged.

  3. Revision 1 · created ·

    Published from osv record GHSA-qqvq-6xgj-jw8g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-5217

Advisory: Electron affected by libvpx's heap buffer overflow in vp8 encoding
IDs: CVE-2023-5217, GHSA-qqvq-6xgj-jw8g
Record: https://patchnext.com/advisories/cve-2023-5217 (revision 3, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: electron 27.0.0-beta.8, 26.2.4, 25.8.4, 24.8.5, 22.3.25. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm electron: affected < 22.3.25; >= 24.0.0, < 24.8.5; >= 25.0.0, < 25.8.4; >= 26.0.0, < 26.2.4; >= 27.0.0-alpha.1, < 27.0.0-beta.8; fixed in 26.2.4, 25.8.4, 27.0.0-beta.8, 24.8.5, 22.3.25

## Suggested inspection (read-only)
- `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on electron.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qqvq-6xgj-jw8g (OSV record GHSA-qqvq-6xgj-jw8g lists affected ranges: npm electron >=0 =24.0.0 =25.0.0 =26.0.0 =27.0.0-alpha.1 <27.0.0-beta.8 (fixed))
- Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2023-5217 to the Known Exploited Vulnerabilities catalog on 2023-10-02.)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2023-5217 to the Known Exploited Vulnerabilities catalog on 2023-10-02.)
- Verified: https://github.com/advisories/GHSA-qqvq-6xgj-jw8g (GitHub-reviewed advisory GHSA-qqvq-6xgj-jw8g lists affected ranges: npm electron >=0 =24.0.0 =25.0.0 =26.0.0 =27.0.0-alpha.1 <27.0.0-beta.8)

Commands are suggestions: review each one before running it.

Loading voting…