Skip to content

← Actionable
Low, CVSS 3.3

Winter CMS Local File Inclusion through Server Side Template Injection

CVE-2023-52085GHSA-2x7r-93ww-cxrq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (winter/wn-backend-module 1.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2023-52085: 30.17% estimated exploitation activity in the next 30 days; percentile 98.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users with access to backend forms that include a ColorPicker FormWidget can provide a value that would then be included without further processing in the compilation of custom stylesheets via LESS. This had the potential to lead to a Local File Inclusion vulnerability. By default, only the Brand Settings (backend.managebranding) and Mail Brand Settings (system.managemailtemplates) forms both include the colorpicker formwidget and pass the provided value to be compiled in LESS, however it is also common for themes to include it on their Theme Customization (cms.managethemeoptions) form and it is technically possible for the values on that form to also be used in LESS compilation: https://wintercms.com/docs/v1.2/docs/themes/development#asset-compiler-variables. Patches This issue has been patched in v1.2.4. Workarounds Apply https://github.com/wintercms/winter/commit/5bc9257fe2bc47d8b786a1b1bf96bafad23d8ddd manually if unable to upgrade to v1.2.4.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2x7r-93ww-cxrq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-52085

Advisory: Winter CMS Local File Inclusion through Server Side Template Injection
IDs: CVE-2023-52085, GHSA-2x7r-93ww-cxrq
Record: https://patchnext.com/advisories/cve-2023-52085 (revision 1, source checked 26 Oct 2026, 14:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: winter/wn-backend-module 1.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist winter/wn-backend-module: affected < 1.2.4; fixed in 1.2.4

## Suggested inspection (read-only)
- Packagist winter/wn-backend-module: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on winter/wn-backend-module.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2x7r-93ww-cxrq (GitHub-reviewed advisory GHSA-2x7r-93ww-cxrq lists affected ranges: Packagist winter/wn-backend-module >=0 <1.2.4)

Commands are suggestions: review each one before running it.

Loading voting…