Skip to content

← Actionable
Low, CVSS 2.0

Winter CMS Stored XSS through Backend ColorPicker FormWidget

CVE-2023-52084GHSA-43w4-4j3c-jx29

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (winter/wn-backend-module 1.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2023-52084: 0.31% estimated exploitation activity in the next 30 days; percentile 23.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users with access to backend forms that include a ColorPicker FormWidget can provide a value that would then be rendered unescaped in the backend form, potentially allowing for a stored XSS attack. By default, only the Brand Settings (backend.managebranding) and Mail Brand Settings (system.managemailtemplates) forms include the colorpicker formwidget, however it is also common for theme's to include it on their Theme Customization (cms.managethemeoptions) form. Although this was a security issue, it's important to note that its severity is relatively low. To exploit the vulnerability, an attacker would already need to have trusted access to the Winter CMS backend and they would then need to convince a user with higher privileges than them to visit an affected Form in the backend. These two factors limit the potential harm of this vulnerability. That being said, all users are advised to update to the latest version (1.2.4) to ensure their systems remain secure. Patches This…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-43w4-4j3c-jx29

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-52084

Advisory: Winter CMS Stored XSS through Backend ColorPicker FormWidget
IDs: CVE-2023-52084, GHSA-43w4-4j3c-jx29
Record: https://patchnext.com/advisories/cve-2023-52084 (revision 1, source checked 26 Oct 2026, 14:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: winter/wn-backend-module 1.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist winter/wn-backend-module: affected < 1.2.4; fixed in 1.2.4

## Suggested inspection (read-only)
- Packagist winter/wn-backend-module: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on winter/wn-backend-module.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-43w4-4j3c-jx29 (GitHub-reviewed advisory GHSA-43w4-4j3c-jx29 lists affected ranges: Packagist winter/wn-backend-module >=0 <1.2.4)

Commands are suggestions: review each one before running it.

Loading voting…