ewen-lbh/ffcss Late-Unicode normalization vulnerability
CVE-2023-52081GHSA-wpmx-564x-h2mh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ewen-lbh/ffcss 0.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.2.0
- Fixed in
- 0.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wpmx-564x-h2mh lists affected ranges: Go github.com/ewen-lbh/ffcss >=0 <0.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2023-52081: 0.52% estimated exploitation activity in the next 30 days; percentile 44.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The function lookupPreprocess() is meant to apply some transformations to a string by disabling characters in the regex [- .]. However, due to the use of late Unicode normalization of type NFKD, it is possible to bypass that validation and re-introduce all the characters in the regex [- .]. Take the following equivalent Unicode character U+2024 (․). Initially, the lookupPreprocess() function would compile the regex and replace the regular dot (.). However, the U+2024 (․) would bypass the ReplaceAllString(). When the normalization operation is applied to U+2024 (․), the resulting character will be U+002E (.). Thus, the dot was reintroduced back. Impact The lookupPreprocess() can be easily bypassed with equivalent Unicode characters like U+FE4D (﹍), which would result in the omitted U+005F (), for instance. It should be noted here that the variable s is user-controlled data coming from /cmd/ffcss/commands.go#L22-L28 the command args. The lookupPreprocess() function is only ever…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wpmx-564x-h2mh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-52081 Advisory: ewen-lbh/ffcss Late-Unicode normalization vulnerability IDs: CVE-2023-52081, GHSA-wpmx-564x-h2mh Record: https://patchnext.com/advisories/cve-2023-52081 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/ewen-lbh/ffcss 0.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/ewen-lbh/ffcss: affected < 0.2.0; fixed in 0.2.0 ## Suggested inspection (read-only) - Go github.com/ewen-lbh/ffcss: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/ewen-lbh/ffcss. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wpmx-564x-h2mh (GitHub-reviewed advisory GHSA-wpmx-564x-h2mh lists affected ranges: Go github.com/ewen-lbh/ffcss >=0 <0.2.0) Commands are suggestions: review each one before running it.
Loading voting…