Mattermost Incorrect Authorization vulnerability
CVE-2023-5193GHSA-h8wh-f7gw-fwpr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 8.1.1, 8.0.2; github.com/mattermost/mattermost-server/v6 7.8.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- >= 8.1.0, <= 8.1.0>= 8.0.0, < 8.0.2
- Fixed in
- 8.0.2, 8.1.1
Go github.com/mattermost/mattermost-server/v6
- Affected
- < 7.8.10
- Fixed in
- 7.8.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h8wh-f7gw-fwpr lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=8.1.0 =8.0.0 =0 <7.8.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-5193: 0.57% estimated exploitation activity in the next 30 days; percentile 47.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost fails to properly check permissions when retrieving a post allowing for a System Role with the permission to manage channels to read the posts of a DM conversation.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h8wh-f7gw-fwpr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-5193 Advisory: Mattermost Incorrect Authorization vulnerability IDs: CVE-2023-5193, GHSA-h8wh-f7gw-fwpr Record: https://patchnext.com/advisories/cve-2023-5193 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.1.1, 8.0.2; github.com/mattermost/mattermost-server/v6 7.8.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected >= 8.1.0, <= 8.1.0; >= 8.0.0, < 8.0.2; fixed in 8.0.2, 8.1.1 - Go github.com/mattermost/mattermost-server/v6: affected < 7.8.10; fixed in 7.8.10 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server/v6: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v6. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h8wh-f7gw-fwpr (GitHub-reviewed advisory GHSA-h8wh-f7gw-fwpr lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=8.1.0 =8.0.0 =0 <7.8.10) Commands are suggestions: review each one before running it.
Loading voting…