Skip to content

← Actionable
Unrated

json-jwt allows bypass of identity checks via a sign/encryption confusion attack

CVE-2023-51774GHSA-c8v6-786g-vjx6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (json-jwt 1.16.6, 1.15.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems json-jwt

    Affected
    >= 1.16.0, < 1.16.6< 1.15.3.1
    Fixed in
    1.16.6, 1.15.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2023-51774: 0.23% estimated exploitation activity in the next 30 days; percentile 14.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The json-jwt (aka JSON::JWT) gem 1.16.x before 1.16.6, 1.15.x before 1.15.3.1 for Ruby sometimes allows bypass of identity checks via a sign/encryption confusion attack. For example, JWE can sometimes be used to bypass JSON::JWT.decode.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c8v6-786g-vjx6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-51774

Advisory: json-jwt allows bypass of identity checks via a sign/encryption confusion attack
IDs: CVE-2023-51774, GHSA-c8v6-786g-vjx6
Record: https://patchnext.com/advisories/cve-2023-51774 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: json-jwt 1.16.6, 1.15.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems json-jwt: affected >= 1.16.0, < 1.16.6; < 1.15.3.1; fixed in 1.16.6, 1.15.3.1

## Suggested inspection (read-only)
- RubyGems json-jwt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on json-jwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c8v6-786g-vjx6 (GitHub-reviewed advisory GHSA-c8v6-786g-vjx6 lists affected ranges: RubyGems json-jwt >=1.16.0 =0 <1.15.3.1)

Commands are suggestions: review each one before running it.

Loading voting…