Skip to content

← Actionable
Medium, CVSS 6.5amended

Apache Airflow CNCF Kubernetes provider, Apache Airflow: Kubernetes configuration file saved without encryption in the Metadata and logged as plain text in the Triggerer service

CVE-2023-51702GHSA-mg2x-mggj-6955

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-cncf-kubernetes 7.0.0; apache-airflow 2.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-51702: 0.39% estimated exploitation activity in the next 30 days; percentile 32.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Since version 5.2.0, when using deferrable mode with the path of a Kubernetes configuration file for authentication, the Airflow worker serializes this configuration file as a dictionary and sends it to the triggerer by storing it in metadata without any encryption. Additionally, if used with an Airflow version between 2.3.0 and 2.6.0, the configuration dictionary will be logged as plain text in the triggerer service without masking. This allows anyone with access to the metadata or triggerer log to obtain the configuration file and use it to access the Kubernetes cluster. This behavior was changed in version 7.0.0, which stopped serializing the file contents and started providing the file path instead to read the contents into the trigger. Users are recommended to upgrade to version 7.0.0, which fixes this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mg2x-mggj-6955

  2. Revision 1 · created ·

    Published from osv record GHSA-mg2x-mggj-6955

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-51702

Advisory: Apache Airflow CNCF Kubernetes provider, Apache Airflow: Kubernetes configuration file saved without encryption in the Metadata and logged as plain text in the Triggerer service
IDs: CVE-2023-51702, GHSA-mg2x-mggj-6955
Record: https://patchnext.com/advisories/cve-2023-51702 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-cncf-kubernetes 7.0.0; apache-airflow 2.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow-providers-cncf-kubernetes: affected >= 5.2.0, < 7.0.0; fixed in 7.0.0
- PyPI apache-airflow: affected >= 2.3.0, < 2.6.1; fixed in 2.6.1

## Suggested inspection (read-only)
- `python -m pip show apache-airflow-providers-cncf-kubernetes`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow-providers-cncf-kubernetes, apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mg2x-mggj-6955 (OSV record GHSA-mg2x-mggj-6955 lists affected ranges: PyPI apache-airflow >=2.3.0 =5.2.0 <7.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mg2x-mggj-6955 (GitHub-reviewed advisory GHSA-mg2x-mggj-6955 lists affected ranges: PyPI apache-airflow >=2.3.0 =5.2.0 <7.0.0)

Commands are suggestions: review each one before running it.

Loading voting…