Fluid vulnerable to OS Command Injection for Fluid Users with JuicefsRuntime
CVE-2023-51699GHSA-wx8q-4gm9-rj2g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/fluid-cloudnative/fluid 0.9.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/fluid-cloudnative/fluid
- Affected
- < 0.9.3
- Fixed in
- 0.9.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wx8q-4gm9-rj2g lists affected ranges: Go github.com/fluid-cloudnative/fluid >=0 <0.9.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.0 · CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-51699: 0.61% estimated exploitation activity in the next 30 days; percentile 49.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact OS command injection vulnerability within the Fluid project's JuicefsRuntime can potentially allow an authenticated user, who has the authority to create or update the K8s CRD Dataset/JuicefsRuntime, to execute arbitrary OS commands within the juicefs related containers. This could lead to unauthorized access, modification or deletion of data. Patches For users who're using version < 0.9.3 with JuicefsRuntime, upgrade to v0.9.3. References Are there any links users can visit to find out more? Credits Special thanks to the discovers of this issue: Xiaozheng Zhang xiaozhengzhang@outlook.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wx8q-4gm9-rj2g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-51699 Advisory: Fluid vulnerable to OS Command Injection for Fluid Users with JuicefsRuntime IDs: CVE-2023-51699, GHSA-wx8q-4gm9-rj2g Record: https://patchnext.com/advisories/cve-2023-51699 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/fluid-cloudnative/fluid 0.9.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/fluid-cloudnative/fluid: affected < 0.9.3; fixed in 0.9.3 ## Suggested inspection (read-only) - Go github.com/fluid-cloudnative/fluid: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/fluid-cloudnative/fluid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wx8q-4gm9-rj2g (GitHub-reviewed advisory GHSA-wx8q-4gm9-rj2g lists affected ranges: Go github.com/fluid-cloudnative/fluid >=0 <0.9.3) Commands are suggestions: review each one before running it.
Loading voting…