Skip to content

← Actionable
High, CVSS 8.4

Wasmer filesystem sandbox not enforced

CVE-2023-51661GHSA-4mq4-7rw3-vm5j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wasmer-cli 4.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io wasmer-cli

    Affected
    >= 3.0.0, < 4.2.4
    Fixed in
    4.2.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-51661: 0.60% estimated exploitation activity in the next 30 days; percentile 48.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary As of Wasmer version v4.2.3, Wasm programs can access the filesystem outside of the sandbox. Details https://github.com/wasmerio/wasmer/issues/4267 PoC A minimal Rust program: This should be compiled with cargo build --target wasm32-wasi. The compiled program, when run with wasmer WITHOUT --dir, can still create a file in the working directory. Impact Service providers running untrusted Wasm code on Wasmer can unexpectedly expose the host filesystem.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4mq4-7rw3-vm5j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-51661

Advisory: Wasmer filesystem sandbox not enforced
IDs: CVE-2023-51661, GHSA-4mq4-7rw3-vm5j
Record: https://patchnext.com/advisories/cve-2023-51661 (revision 1, source checked 26 Oct 2026, 15:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wasmer-cli 4.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io wasmer-cli: affected >= 3.0.0, < 4.2.4; fixed in 4.2.4

## Suggested inspection (read-only)
- crates.io wasmer-cli: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wasmer-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4mq4-7rw3-vm5j (GitHub-reviewed advisory GHSA-4mq4-7rw3-vm5j lists affected ranges: crates.io wasmer-cli >=3.0.0 <4.2.4)

Commands are suggestions: review each one before running it.

Loading voting…