Potential URI resolution path traversal in the AWS SDK for PHP
CVE-2023-51651GHSA-557v-xcg6-rm5m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (aws/aws-sdk-php 3.288.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist aws/aws-sdk-php
- Affected
- < 3.288.1
- Fixed in
- 3.288.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-557v-xcg6-rm5m lists affected ranges: Packagist aws/aws-sdk-php >=0 <3.288.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.0 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-51651: 0.38% estimated exploitation activity in the next 30 days; percentile 31.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Within the scope of requests to S3 object keys and/or prefixes containing a Unix double-dot, a URI path traversal is possible. The issue exists in thebuildEndpoint method in the RestSerializer component of the AWS SDK for PHP v3 prior to 3.288.1. The buildEndpoint method relies on the Guzzle Psr7 UriResolver utility, which strips dot segments from the request path in accordance with RFC 3986. Under certain conditions, this could lead to an arbitrary object being accessed. Versions of the AWS SDK for PHP v3 before 3.288.1 are affected by this issue. Patches Upgrade to the AWS SDK for PHP = 3.288.1, if you are on version < 3.288.1. References RFC 3986 - https://datatracker.ietf.org/doc/html/rfc3986 For more information If you have any questions or comments about this advisory, please contact AWS's Security team.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-557v-xcg6-rm5m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-51651 Advisory: Potential URI resolution path traversal in the AWS SDK for PHP IDs: CVE-2023-51651, GHSA-557v-xcg6-rm5m Record: https://patchnext.com/advisories/cve-2023-51651 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: aws/aws-sdk-php 3.288.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist aws/aws-sdk-php: affected < 3.288.1; fixed in 3.288.1 ## Suggested inspection (read-only) - Packagist aws/aws-sdk-php: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on aws/aws-sdk-php. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-557v-xcg6-rm5m (GitHub-reviewed advisory GHSA-557v-xcg6-rm5m lists affected ranges: Packagist aws/aws-sdk-php >=0 <3.288.1) Commands are suggestions: review each one before running it.
Loading voting…