Gradio makes the /file secure against file traversal and server-side request forgery attacks
CVE-2023-51449GHSA-6qm2-wpxq-7qh2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gradio 4.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI gradio
- Affected
- < 4.11.0
- Fixed in
- 4.11.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6qm2-wpxq-7qh2 lists affected ranges: PyPI gradio >=0 <4.11.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6qm2-wpxq-7qh2 lists affected ranges: PyPI gradio >=0 <4.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- EPSS
- CVE-2023-51449: 28.34% estimated exploitation activity in the next 30 days; percentile 98.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Older versions of gradio contained a vulnerability in the /file route which made them susceptible to file traversal attacks in which an attacker could access arbitrary files on a machine running a Gradio app with a public URL (e.g. if the demo was created with share=True, or on Hugging Face Spaces) if they knew the path of files to look for. This was not possible through regular URLs passed into a browser, but it was possible through the use of programmatic tools such as curl with the --pass-as-is flag. Furthermore, the /file route in Gradio apps also contained a vulnerability that made it possible to use it for SSRF attacks. Both of these vulnerabilities have been fixed in gradio==4.11.0
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6qm2-wpxq-7qh2
- Revision 1 · created ·
Published from osv record GHSA-6qm2-wpxq-7qh2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-51449 Advisory: Gradio makes the `/file` secure against file traversal and server-side request forgery attacks IDs: CVE-2023-51449, GHSA-6qm2-wpxq-7qh2 Record: https://patchnext.com/advisories/cve-2023-51449 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gradio 4.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI gradio: affected < 4.11.0; fixed in 4.11.0 ## Suggested inspection (read-only) - `python -m pip show gradio`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gradio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6qm2-wpxq-7qh2 (OSV record GHSA-6qm2-wpxq-7qh2 lists affected ranges: PyPI gradio >=0 <4.11.0 (fixed)) - Verified: https://github.com/advisories/GHSA-6qm2-wpxq-7qh2 (GitHub-reviewed advisory GHSA-6qm2-wpxq-7qh2 lists affected ranges: PyPI gradio >=0 <4.11.0) Commands are suggestions: review each one before running it.
Loading voting…