Cross-site scripting (XSS) in the dynamic file uploads
CVE-2023-51447GHSA-9w99-78rj-hmxq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim 0.27.5; decidim-core 0.27.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems decidim
- Affected
- >= 0.27.0, < 0.27.5
- Fixed in
- 0.27.5
RubyGems decidim-core
- Affected
- >= 0.27.0, < 0.27.5
- Fixed in
- 0.27.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9w99-78rj-hmxq lists affected ranges: RubyGems decidim >=0.27.0 =0.27.0 <0.27.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
- EPSS
- CVE-2023-51447: 0.49% estimated exploitation activity in the next 30 days; percentile 42.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The dynamic file upload feature is subject to potential XSS attach in case the attacker manages to modify the file names of the records being uploaded to the server. This appears in sections where the user controls the file upload dialogs themselves and has the technical knowledge to change the file names through the dynamic upload endpoint. Therefore I believe it would require the attacker to control the whole session of the particular user but in any case, this needs to be fixed. Successful exploit of this vulneratibility would require the user to have successfully uploaded a file blob to the server with a malicious file name and then have the possibility to direct the other user to the edit page of the record where the attachment is attached. The users are able to craft the direct upload requests themselves controlling the file name that gets stored to the database as shown here:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9w99-78rj-hmxq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-51447 Advisory: Cross-site scripting (XSS) in the dynamic file uploads IDs: CVE-2023-51447, GHSA-9w99-78rj-hmxq Record: https://patchnext.com/advisories/cve-2023-51447 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: decidim 0.27.5; decidim-core 0.27.5. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems decidim: affected >= 0.27.0, < 0.27.5; fixed in 0.27.5 - RubyGems decidim-core: affected >= 0.27.0, < 0.27.5; fixed in 0.27.5 ## Suggested inspection (read-only) - RubyGems decidim: check the installed version with your package manager. - RubyGems decidim-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on decidim, decidim-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9w99-78rj-hmxq (GitHub-reviewed advisory GHSA-9w99-78rj-hmxq lists affected ranges: RubyGems decidim >=0.27.0 =0.27.0 <0.27.5) Commands are suggestions: review each one before running it.
Loading voting…