Stored Cross-Site Scripting (XSS) vulnerability in GeoServer's REST Resources API
CVE-2023-51445GHSA-fh7p-5f6g-vj2w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver:gs-restconfig 2.23.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.geoserver:gs-restconfig
- Affected
- < 2.23.3
- Fixed in
- 2.23.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fh7p-5f6g-vj2w lists affected ranges: Maven org.geoserver:gs-restconfig >=0 <2.23.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-51445: 0.49% estimated exploitation activity in the next 30 days; percentile 41.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored cross-site scripting (XSS) vulnerability exists that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in uploaded style/legend resources that will execute in the context of another administrator's browser when viewed in the REST Resources API. Access to the REST Resources API is limited to full administrators by default and granting non-administrators access to this endpoint should be carefully considered as it may allow access to files containing sensitive information. Details Upload a new Legend via the New Style page if user has permissions for this. This file is then not checked and is uploaded to the backend system. This file can then be viewed directly by requesting it via the API which will then view the file in its raw format without sanitisation. PoC 1 .User makes the following request to upload file. 2. File is uploaded to the backend system and is viewable via the API at - /geoserver/rest/resourse/styles…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fh7p-5f6g-vj2w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-51445 Advisory: Stored Cross-Site Scripting (XSS) vulnerability in GeoServer's REST Resources API IDs: CVE-2023-51445, GHSA-fh7p-5f6g-vj2w Record: https://patchnext.com/advisories/cve-2023-51445 (revision 1, source checked 26 Oct 2026, 16:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.geoserver:gs-restconfig 2.23.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.geoserver:gs-restconfig: affected < 2.23.3; fixed in 2.23.3 ## Suggested inspection (read-only) - Maven org.geoserver:gs-restconfig: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.geoserver:gs-restconfig. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fh7p-5f6g-vj2w (GitHub-reviewed advisory GHSA-fh7p-5f6g-vj2w lists affected ranges: Maven org.geoserver:gs-restconfig >=0 <2.23.3) Commands are suggestions: review each one before running it.
Loading voting…