Apache Airflow Improper Access Control vulnerability
CVE-2023-50783GHSA-5938-79hg-xh3q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- < 2.8.0
- Fixed in
- 2.8.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5938-79hg-xh3q lists affected ranges: PyPI apache-airflow >=0 <2.8.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5938-79hg-xh3q lists affected ranges: PyPI apache-airflow >=0 <2.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-50783: 1.39% estimated exploitation activity in the next 30 days; percentile 72.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5938-79hg-xh3q
- Revision 1 · created ·
Published from osv record GHSA-5938-79hg-xh3q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-50783 Advisory: Apache Airflow Improper Access Control vulnerability IDs: CVE-2023-50783, GHSA-5938-79hg-xh3q Record: https://patchnext.com/advisories/cve-2023-50783 (revision 2, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected < 2.8.0; fixed in 2.8.0 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5938-79hg-xh3q (OSV record GHSA-5938-79hg-xh3q lists affected ranges: PyPI apache-airflow >=0 <2.8.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5938-79hg-xh3q (GitHub-reviewed advisory GHSA-5938-79hg-xh3q lists affected ranges: PyPI apache-airflow >=0 <2.8.0) Commands are suggestions: review each one before running it.
Loading voting…