Skip to content

← Actionable
High, CVSS 7.5

Grackle has StackOverflowError in GraphQL query processing

CVE-2023-50730GHSA-g56x-7j6w-g8r8

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.typelevel:grackle-core_3

    Affected
    < 0.18.0
    Fixed in
    0.18.0
  • Maven org.typelevel:grackle-core_native0.4_3

    Affected
    < 0.18.0
    Fixed in
    0.18.0
  • Maven edu.gemini:gsp-graphql-core_3

    Affected
    <= 0.14.0
    Fixed in
    no fixed version recorded
  • Maven org.typelevel:grackle-core_native0.4_2.13

    Affected
    < 0.18.0
    Fixed in
    0.18.0
  • Maven edu.gemini:gsp-graphql-core_sjs1_3

    Affected
    <= 0.14.0
    Fixed in
    no fixed version recorded
  • Maven edu.gemini:gsp-graphql-core_native0.4_2.13

    Affected
    <= 0.14.0
    Fixed in
    no fixed version recorded
  • Maven org.typelevel:grackle-core_sjs1_3

    Affected
    < 0.18.0
    Fixed in
    0.18.0
  • Maven edu.gemini:gsp-graphql-core_2.13

    Affected
    <= 0.14.0
    Fixed in
    no fixed version recorded
  • Maven edu.gemini:gsp-graphql-core_sjs1_2.13

    Affected
    <= 0.14.0
    Fixed in
    no fixed version recorded
  • Maven edu.gemini:gsp-graphql-core_native0.4_3

    Affected
    <= 0.14.0
    Fixed in
    no fixed version recorded
  • Maven org.typelevel:grackle-core_sjs1_2.13

    Affected
    < 0.18.0
    Fixed in
    0.18.0
  • Maven org.typelevel:grackle-core_2.13

    Affected
    < 0.18.0
    Fixed in
    0.18.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-50730: 0.83% estimated exploitation activity in the next 30 days; percentile 57.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Prior to this fix, the GraphQL query parsing was vulnerable to StackOverflowErrors. The possibility of small queries resulting in stack overflow is a potential denial of service vulnerability. This potentially affects all applications using Grackle which have untrusted users. [!CAUTION] No specific knowledge of an application's GraphQL schema would be required to construct a pathological query. Patches The stack overflow issues have been resolved in the v0.18.0 release of Grackle. Workarounds Users could interpose a sanitizing layer in between untrusted input and Grackle query processing.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g56x-7j6w-g8r8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-50730

Advisory: Grackle has StackOverflowError in GraphQL query processing
IDs: CVE-2023-50730, GHSA-g56x-7j6w-g8r8
Record: https://patchnext.com/advisories/cve-2023-50730 (revision 1, source checked 26 Oct 2026, 16:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.typelevel:grackle-core_3 0.18.0; org.typelevel:grackle-core_native0.4_3 0.18.0; org.typelevel:grackle-core_native0.4_2.13 0.18.0; org.typelevel:grackle-core_sjs1_3 0.18.0; org.typelevel:grackle-core_sjs1_2.13 0.18.0; org.typelevel:grackle-core_2.13 0.18.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.typelevel:grackle-core_3: affected < 0.18.0; fixed in 0.18.0
- Maven org.typelevel:grackle-core_native0.4_3: affected < 0.18.0; fixed in 0.18.0
- Maven edu.gemini:gsp-graphql-core_3: affected <= 0.14.0
- Maven org.typelevel:grackle-core_native0.4_2.13: affected < 0.18.0; fixed in 0.18.0
- Maven edu.gemini:gsp-graphql-core_sjs1_3: affected <= 0.14.0
- Maven edu.gemini:gsp-graphql-core_native0.4_2.13: affected <= 0.14.0
- Maven org.typelevel:grackle-core_sjs1_3: affected < 0.18.0; fixed in 0.18.0
- Maven edu.gemini:gsp-graphql-core_2.13: affected <= 0.14.0
- Maven edu.gemini:gsp-graphql-core_sjs1_2.13: affected <= 0.14.0
- Maven edu.gemini:gsp-graphql-core_native0.4_3: affected <= 0.14.0
- Maven org.typelevel:grackle-core_sjs1_2.13: affected < 0.18.0; fixed in 0.18.0
- Maven org.typelevel:grackle-core_2.13: affected < 0.18.0; fixed in 0.18.0

## Suggested inspection (read-only)
- Maven org.typelevel:grackle-core_3: check the installed version with your package manager.
- Maven org.typelevel:grackle-core_native0.4_3: check the installed version with your package manager.
- Maven edu.gemini:gsp-graphql-core_3: check the installed version with your package manager.
- Maven org.typelevel:grackle-core_native0.4_2.13: check the installed version with your package manager.
- Maven edu.gemini:gsp-graphql-core_sjs1_3: check the installed version with your package manager.
- Maven edu.gemini:gsp-graphql-core_native0.4_2.13: check the installed version with your package manager.
- Maven org.typelevel:grackle-core_sjs1_3: check the installed version with your package manager.
- Maven edu.gemini:gsp-graphql-core_2.13: check the installed version with your package manager.
- Maven edu.gemini:gsp-graphql-core_sjs1_2.13: check the installed version with your package manager.
- Maven edu.gemini:gsp-graphql-core_native0.4_3: check the installed version with your package manager.
- Maven org.typelevel:grackle-core_sjs1_2.13: check the installed version with your package manager.
- Maven org.typelevel:grackle-core_2.13: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.typelevel:grackle-core_3, org.typelevel:grackle-core_native0.4_3, edu.gemini:gsp-graphql-core_3, org.typelevel:grackle-core_native0.4_2.13, edu.gemini:gsp-graphql-core_sjs1_3, edu.gemini:gsp-graphql-core_native0.4_2.13, org.typelevel:grackle-core_sjs1_3, edu.gemini:gsp-graphql-core_2.13, edu.gemini:gsp-graphql-core_sjs1_2.13, edu.gemini:gsp-graphql-core_native0.4_3, org.typelevel:grackle-core_sjs1_2.13, org.typelevel:grackle-core_2.13.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g56x-7j6w-g8r8 (GitHub-reviewed advisory GHSA-g56x-7j6w-g8r8 lists affected ranges: Maven org.typelevel:grackle-core_2.13 >=0 =0 =0 =0 =0 =0 =0 =0 <=0.14.0;…)

Commands are suggestions: review each one before running it.

Loading voting…