Skip to content

← Actionable
High, CVSS 8.2amended

Unauthenticated Denial of Service in the octokit/webhooks library

CVE-2023-50728GHSA-pwfr-8pq7-x9qv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (octokit 3.1.2; probot 12.3.3; @octokit/app 14.0.2; @octokit/webhooks 12.0.3, 11.1.2, 10.9.2, 9.26.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm octokit

    Affected
    < 3.1.2
    Fixed in
    3.1.2
  • npm probot

    Affected
    < 12.3.3
    Fixed in
    12.3.3
  • npm @octokit/app

    Affected
    >= 14.0.1, <= 14.0.1
    Fixed in
    14.0.2
  • npm @octokit/webhooks

    Affected
    < 9.26.3>= 10.0.0, < 10.9.2>= 11.0.0, < 11.1.2>= 12.0.0, < 12.0.3
    Fixed in
    9.26.3, 11.1.2, 12.0.3, 10.9.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2023-50728: 0.90% estimated exploitation activity in the next 30 days; percentile 59.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Versions v9.26.0, v10.9.x), v11.1.x, v12.0.x all contained the code that would throw the error. Specifically, during a pentest we encountered a bug in the octokit/webhooks library (a dependency of Probot, a framework for building Github Apps). The resulting request was found to cause an uncaught exception that ends the nodejs process. The problem is caused by an issue with error handling in the @octokit/webhooks library because the error can be undefined in some cases. Credit goes to @pb82 (for the early analysis) and @rh-tguittet (for discovery). Patches Maintenance releases for the Error being thrown by the verify method in octokit/webhooks.js v12 - v12.0.4 v11 - v11.1.2 v10 -v10.9.2 v9 - v9.26.3 Maintenance release for the reference for octokit/webhooks.js in app.js v14.0.2 Maintenance release for the reference for octokit/webhooks.js in octokit.js v3.1.2 Maintenance release for the reference for octokit/webhooks.js in Protobot v12.3.3 Workarounds It is recommend that all…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pwfr-8pq7-x9qv

  2. Revision 1 · created ·

    Published from osv record GHSA-pwfr-8pq7-x9qv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-50728

Advisory: Unauthenticated Denial of Service in the octokit/webhooks library
IDs: CVE-2023-50728, GHSA-pwfr-8pq7-x9qv
Record: https://patchnext.com/advisories/cve-2023-50728 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: octokit 3.1.2; probot 12.3.3; @octokit/app 14.0.2; @octokit/webhooks 12.0.3, 11.1.2, 10.9.2, 9.26.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm octokit: affected < 3.1.2; fixed in 3.1.2
- npm probot: affected < 12.3.3; fixed in 12.3.3
- npm @octokit/app: affected >= 14.0.1, <= 14.0.1; fixed in 14.0.2
- npm @octokit/webhooks: affected < 9.26.3; >= 10.0.0, < 10.9.2; >= 11.0.0, < 11.1.2; >= 12.0.0, < 12.0.3; fixed in 9.26.3, 11.1.2, 12.0.3, 10.9.2

## Suggested inspection (read-only)
- `npm ls octokit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls probot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @octokit/app --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @octokit/webhooks --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on octokit, probot, @octokit/app, @octokit/webhooks.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pwfr-8pq7-x9qv (OSV record GHSA-pwfr-8pq7-x9qv lists affected ranges: npm @octokit/webhooks >=0 =10.0.0 =11.0.0 =12.0.0 =14.0.1 =0 =0 <12.3.3 (fixed))
- Verified: https://github.com/advisories/GHSA-pwfr-8pq7-x9qv (GitHub-reviewed advisory GHSA-pwfr-8pq7-x9qv lists affected ranges: npm @octokit/webhooks >=0 =10.0.0 =11.0.0 =12.0.0 =14.0.1 =0 =0 <12.3.3)

Commands are suggestions: review each one before running it.

Loading voting…