Skip to content

← Actionable
Medium, CVSS 6.3

Resque vulnerable to reflected XSS in resque-web failed and queues lists

CVE-2023-50725GHSA-gc3j-vvwf-4rp8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (resque 2.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems resque

    Affected
    < 2.2.1
    Fixed in
    2.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N
EPSS
  • CVE-2023-50725: 0.53% estimated exploitation activity in the next 30 days; percentile 44.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The following paths in resque-web have been found to be vulnerable to reflected XSS: Patches v2.2.1 Workarounds No known workarounds at this time. It is recommended to not click on 3rd party or untrusted links to the resque-web interface until you have patched your application. References https://github.com/resque/resque/pull/1790

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gc3j-vvwf-4rp8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-50725

Advisory: Resque vulnerable to reflected XSS in resque-web failed and queues lists
IDs: CVE-2023-50725, GHSA-gc3j-vvwf-4rp8
Record: https://patchnext.com/advisories/cve-2023-50725 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: resque 2.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems resque: affected < 2.2.1; fixed in 2.2.1

## Suggested inspection (read-only)
- RubyGems resque: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on resque.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gc3j-vvwf-4rp8 (GitHub-reviewed advisory GHSA-gc3j-vvwf-4rp8 lists affected ranges: RubyGems resque >=0 <2.2.1)

Commands are suggestions: review each one before running it.

Loading voting…