XSS/CSRF Remote Code Execution in XWiki.ConfigurableClass
CVE-2023-50722GHSA-cp3j-273x-3jxc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-administration-ui 15.7-rc-1, 15.5.2, 14.10.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-administration-ui
- Affected
- >= 2.3, < 14.10.15>= 15.0-rc-1, < 15.5.2>= 15.6-rc-1, < 15.7-rc-1
- Fixed in
- 14.10.15, 15.5.2, 15.7-rc-1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cp3j-273x-3jxc lists affected ranges: Maven org.xwiki.platform:xwiki-platform-administration-ui >=2.3 =15.0-rc-1 =15.6-rc-1 <15.7-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-50722: 0.66% estimated exploitation activity in the next 30 days; percentile 51.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There is a reflected XSS or also direct remote code execution vulnerability in the code for displaying configurable admin sections. The code that can be passed through a URL parameter is only executed when the user who is visiting the crafted URL has edit right on at least one configuration section. While any user of the wiki could easily create such a section, in this case it is much more convenient to exploit GHSA-qj86-p74r-7wp5 which is why this attack scenario won't be further considered in the following. In contrast to GHSA-qj86-p74r-7wp5, this vulnerability doesn't require the attacker to have an account or any access on the wiki. It is sufficient to trick any admin user of the XWiki installation to visit the crafted URL. Alternatively, the URL can also be embedded as image source of an image in any content of the wiki like a comment that could be left by an anonymous user. This vulnerability allows full remote code execution with programming rights and thus impacts the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cp3j-273x-3jxc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-50722 Advisory: XSS/CSRF Remote Code Execution in XWiki.ConfigurableClass IDs: CVE-2023-50722, GHSA-cp3j-273x-3jxc Record: https://patchnext.com/advisories/cve-2023-50722 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-administration-ui 15.7-rc-1, 15.5.2, 14.10.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-administration-ui: affected >= 2.3, < 14.10.15; >= 15.0-rc-1, < 15.5.2; >= 15.6-rc-1, < 15.7-rc-1; fixed in 14.10.15, 15.5.2, 15.7-rc-1 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-administration-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-administration-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cp3j-273x-3jxc (GitHub-reviewed advisory GHSA-cp3j-273x-3jxc lists affected ranges: Maven org.xwiki.platform:xwiki-platform-administration-ui >=2.3 =15.0-rc-1 =15.6-rc-1 <15.7-rc-1) Commands are suggestions: review each one before running it.
Loading voting…