NocoDB Allows Preview of Files with Dangerous Content
CVE-2023-50717GHSA-qg73-g3cf-vhhh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nocodb 0.202.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nocodb
- Affected
- >= 0.202.6, <= 0.202.9
- Fixed in
- 0.202.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qg73-g3cf-vhhh lists affected ranges: npm nocodb >=0.202.6 <0.202.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qg73-g3cf-vhhh lists affected ranges: npm nocodb >=0.202.6 <=0.202.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-50717: 0.57% estimated exploitation activity in the next 30 days; percentile 47.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary --- Attacker can upload a html file with malicious content. If user tries to open that file in browser malicious scripts can be executed leading Stored XSS(Cross-Site Script) attack. PoC --- NocoDB was configured using the Release Binary Noco-macos-arm64, and nocodb version 0.202.9 (currently the latest version) was used. binary hash infos: md5(164b727f287af56168bc16fba622d0b4) / sha256(43e8e97f4c5f5330613abe071a359f84e4514b7186f92954b678087c37b7832e) <img width="665" alt="image" src="https://user-images.githubusercontent.com/86613161/287472673-aeb60a02-2080-429f-8583-9f130ab62779.png" 1. Run the binary to start the server and access the arbitrary table dashboard. <img width="830" alt="image" src="https://user-images.githubusercontent.com/86613161/287472852-98b2286e-ad66-45bf-b503-63780619d775.png" Here, used the default Features table. 2. Click + in the table field header to add an attachment field. <img width="1173" alt="image"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qg73-g3cf-vhhh
- Revision 1 · created ·
Published from osv record GHSA-qg73-g3cf-vhhh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-50717 Advisory: NocoDB Allows Preview of Files with Dangerous Content IDs: CVE-2023-50717, GHSA-qg73-g3cf-vhhh Record: https://patchnext.com/advisories/cve-2023-50717 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nocodb 0.202.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nocodb: affected >= 0.202.6, <= 0.202.9; fixed in 0.202.10 ## Suggested inspection (read-only) - `npm ls nocodb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nocodb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qg73-g3cf-vhhh (OSV record GHSA-qg73-g3cf-vhhh lists affected ranges: npm nocodb >=0.202.6 <0.202.10 (fixed)) - Verified: https://github.com/advisories/GHSA-qg73-g3cf-vhhh (GitHub-reviewed advisory GHSA-qg73-g3cf-vhhh lists affected ranges: npm nocodb >=0.202.6 <=0.202.9) Commands are suggestions: review each one before running it.
Loading voting…