Skip to content

← Actionable
Medium, CVSS 5.7

serde deserialization for FamStructWrapper lacks bound checks that could potentially lead to out-of-bounds memory access

CVE-2023-50711GHSA-875g-mfp6-g7f9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vmm-sys-util 0.12.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io vmm-sys-util

    Affected
    >= 0.5.0, < 0.12.0
    Fixed in
    0.12.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.7 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:L
EPSS
  • CVE-2023-50711: 0.65% estimated exploitation activity in the next 30 days; percentile 51.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An issue was discovered in the FamStructWrapper::deserialize implementation provided by the crate for vmmsysutil::fam::FamStructWrapper, which can lead to out of bounds memory accesses. The deserialization does not check that the length stored in the header matches the flexible array length. Mismatch in the lengths might allow out of bounds memory access through Rust-safe methods. Impacted versions: = 0.5.0 Patches The issue was corrected in version 0.12.0 by inserting a check that verifies the lengths of compared flexible arrays are equal for any deserialized header and aborting deserialization otherwise. Moreover, the API was changed so that header length can only be modified through Rust-unsafe code. This ensures that users cannot trigger out-of-bounds memory access from Rust-safe code.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-875g-mfp6-g7f9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-50711

Advisory: `serde` deserialization for `FamStructWrapper` lacks bound checks that could potentially lead to out-of-bounds memory access
IDs: CVE-2023-50711, GHSA-875g-mfp6-g7f9
Record: https://patchnext.com/advisories/cve-2023-50711 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vmm-sys-util 0.12.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io vmm-sys-util: affected >= 0.5.0, < 0.12.0; fixed in 0.12.0

## Suggested inspection (read-only)
- crates.io vmm-sys-util: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vmm-sys-util.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-875g-mfp6-g7f9 (GitHub-reviewed advisory GHSA-875g-mfp6-g7f9 lists affected ranges: crates.io vmm-sys-util >=0.5.0 <0.12.0)

Commands are suggestions: review each one before running it.

Loading voting…