yii2-authclient vulnerable to possible timing attack on string comparison in OAuth1, OAuth2 and OpenID Connect implementation
CVE-2023-50708GHSA-w8vh-p74j-x9xp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yiisoft/yii2-authclient 2.2.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist yiisoft/yii2-authclient
- Affected
- <= 2.2.14
- Fixed in
- 2.2.15
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w8vh-p74j-x9xp lists affected ranges: Packagist yiisoft/yii2-authclient >=0 <=2.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2023-50708: 0.72% estimated exploitation activity in the next 30 days; percentile 53.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? Original Report: The Oauth1/2 "state" and OpenID Connect "nonce" is vulnerable for a "timing attack" since it's compared via regular string comparison (instead of Yii::$app-getSecurity()-compareString()). Affected Code: 1. OAuth 1 "state" https://github.com/yiisoft/yii2-authclient/blob/0d1c3880f4d79e20aa1d77c012650b54e69695ff/src/OAuth1.php#L158 3. OAuth 2 "state" https://github.com/yiisoft/yii2-authclient/blob/0d1c3880f4d79e20aa1d77c012650b54e69695ff/src/OAuth2.php#L121 4. OpenID Connect "nonce" https://github.com/yiisoft/yii2-authclient/blob/0d1c3880f4d79e20aa1d77c012650b54e69695ff/src/OpenIdConnect.php#L420 Patches Has the problem been patched? What versions should users upgrade to? TBD: Replace strcmp with Yii::$app-getSecurity()-compareString()). Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? not as far as I see. References Are there any links users can visit to find out more?
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w8vh-p74j-x9xp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-50708 Advisory: yii2-authclient vulnerable to possible timing attack on string comparison in OAuth1, OAuth2 and OpenID Connect implementation IDs: CVE-2023-50708, GHSA-w8vh-p74j-x9xp Record: https://patchnext.com/advisories/cve-2023-50708 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yiisoft/yii2-authclient 2.2.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist yiisoft/yii2-authclient: affected <= 2.2.14; fixed in 2.2.15 ## Suggested inspection (read-only) - Packagist yiisoft/yii2-authclient: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yiisoft/yii2-authclient. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w8vh-p74j-x9xp (GitHub-reviewed advisory GHSA-w8vh-p74j-x9xp lists affected ranges: Packagist yiisoft/yii2-authclient >=0 <=2.2.14) Commands are suggestions: review each one before running it.
Loading voting…