jose2go vulnerable to denial of service via large p2c value
CVE-2023-50658GHSA-6294-6rgp-fr7r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/dvsekhvalnov/jose2go 1.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/dvsekhvalnov/jose2go
- Affected
- < 1.6.0
- Fixed in
- 1.6.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6294-6rgp-fr7r lists affected ranges: Go github.com/dvsekhvalnov/jose2go >=0 <1.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2023-50658: 0.82% estimated exploitation activity in the next 30 days; percentile 57.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The jose2go component before 1.6.0 for Go allows attackers to cause a denial of service (CPU consumption) via a large p2c (aka PBES2 Count) value.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6294-6rgp-fr7r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-50658 Advisory: jose2go vulnerable to denial of service via large p2c value IDs: CVE-2023-50658, GHSA-6294-6rgp-fr7r Record: https://patchnext.com/advisories/cve-2023-50658 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/dvsekhvalnov/jose2go 1.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/dvsekhvalnov/jose2go: affected < 1.6.0; fixed in 1.6.0 ## Suggested inspection (read-only) - Go github.com/dvsekhvalnov/jose2go: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/dvsekhvalnov/jose2go. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6294-6rgp-fr7r (GitHub-reviewed advisory GHSA-6294-6rgp-fr7r lists affected ranges: Go github.com/dvsekhvalnov/jose2go >=0 <1.6.0) Commands are suggestions: review each one before running it.
Loading voting…