Skip to content

← Actionable
Medium, CVSS 5.4amended

Layui cross-site scripting (XSS) vulnerability

CVE-2023-50550GHSA-rcvr-8whx-3m5p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (layui 2.7.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm layui

    Affected
    <= 2.7.4
    Fixed in
    2.7.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-50550: 0.28% estimated exploitation activity in the next 30 days; percentile 20.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

layui up to v2.74 was discovered to contain a cross-site scripting (XSS) vulnerability via the data-content parameter.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rcvr-8whx-3m5p

  2. Revision 1 · created ·

    Published from osv record GHSA-rcvr-8whx-3m5p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-50550

Advisory: Layui cross-site scripting (XSS) vulnerability
IDs: CVE-2023-50550, GHSA-rcvr-8whx-3m5p
Record: https://patchnext.com/advisories/cve-2023-50550 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: layui 2.7.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm layui: affected <= 2.7.4; fixed in 2.7.5

## Suggested inspection (read-only)
- `npm ls layui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on layui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rcvr-8whx-3m5p (OSV record GHSA-rcvr-8whx-3m5p lists affected ranges: npm layui >=0 <2.7.5 (fixed))
- Verified: https://github.com/advisories/GHSA-rcvr-8whx-3m5p (GitHub-reviewed advisory GHSA-rcvr-8whx-3m5p lists affected ranges: npm layui >=0 <=2.7.4)

Commands are suggestions: review each one before running it.

Loading voting…