Insecure Direct Object Reference in extension "Content Consent" (content_consent)
CVE-2023-50462GHSA-j8cw-ppmv-wj85
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (t3s/content-consent 2.0.2, 1.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist t3s/content-consent
- Affected
- >= 2.0.0, < 2.0.2< 1.0.3
- Fixed in
- 2.0.2, 1.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j8cw-ppmv-wj85 lists affected ranges: Packagist t3s/content-consent >=2.0.0 =0 <1.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-50462: 0.32% estimated exploitation activity in the next 30 days; percentile 25.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The extension fails to verify whether a specified content element identifier is permitted by the plugin. This enables an unauthenticated user to display various content elements, leading to an insecure direct object reference (IDOR) vulnerability with the potential to expose internal content elements.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j8cw-ppmv-wj85
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-50462 Advisory: Insecure Direct Object Reference in extension "Content Consent" (content_consent) IDs: CVE-2023-50462, GHSA-j8cw-ppmv-wj85 Record: https://patchnext.com/advisories/cve-2023-50462 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: t3s/content-consent 2.0.2, 1.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist t3s/content-consent: affected >= 2.0.0, < 2.0.2; < 1.0.3; fixed in 2.0.2, 1.0.3 ## Suggested inspection (read-only) - Packagist t3s/content-consent: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on t3s/content-consent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j8cw-ppmv-wj85 (GitHub-reviewed advisory GHSA-j8cw-ppmv-wj85 lists affected ranges: Packagist t3s/content-consent >=2.0.0 =0 <1.0.3) Commands are suggestions: review each one before running it.
Loading voting…