Skip to content

← Actionable
High, CVSS 8.8

Configuration Injection in extension "Direct Mail" (direct_mail)

CVE-2023-50461GHSA-p6xx-fhfw-7mj7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directmailteam/direct-mail 9.5.2, 7.0.3, 6.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-50461: 0.51% estimated exploitation activity in the next 30 days; percentile 43.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The “Configuration” backend module of the extension allows an authenticated user to write arbitrary page TSConfig for folders configured as “Direct Mail”. Exploiting the vulnerability may lead to Configuration Injection (TYPO3 10.4 and above) and to Arbitrary Code Execution (TYPO3 9.5 and below). A valid backend user account having access to the Direct Mail "Configuration" backend module is needed in order to exploit this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p6xx-fhfw-7mj7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-50461

Advisory: Configuration Injection in extension "Direct Mail" (direct_mail)
IDs: CVE-2023-50461, GHSA-p6xx-fhfw-7mj7
Record: https://patchnext.com/advisories/cve-2023-50461 (revision 1, source checked 26 Oct 2026, 14:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directmailteam/direct-mail 9.5.2, 7.0.3, 6.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist directmailteam/direct-mail: affected >= 8.0.0, < 9.5.2; >= 7.0.0, < 7.0.3; < 6.0.3; fixed in 6.0.3, 9.5.2, 7.0.3

## Suggested inspection (read-only)
- Packagist directmailteam/direct-mail: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directmailteam/direct-mail.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p6xx-fhfw-7mj7 (GitHub-reviewed advisory GHSA-p6xx-fhfw-7mj7 lists affected ranges: Packagist directmailteam/direct-mail >=8.0.0 =7.0.0 =0 <6.0.3)

Commands are suggestions: review each one before running it.

Loading voting…