Apache Solr: Backup/Restore APIs allow for deployment of executables in malicious ConfigSets
CVE-2023-50386GHSA-37vr-vmg4-jwpw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.solr:solr-core 9.4.1, 8.11.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.solr:solr-core
- Affected
- >= 6.0.0, < 8.11.3>= 9.0.0, < 9.4.1
- Fixed in
- 8.11.3, 9.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-37vr-vmg4-jwpw lists affected ranges: Maven org.apache.solr:solr-core >=6.0.0 =9.0.0 <9.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-50386: 83.72% estimated exploitation activity in the next 30 days; percentile 99.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Control of Dynamically-Managed Code Resources, Unrestricted Upload of File with Dangerous Type, Inclusion of Functionality from Untrusted Control Sphere vulnerability in Apache Solr.This issue affects Apache Solr from 6.0.0 through 8.11.2, from 9.0.0 before 9.4.1. In the affected versions, Solr ConfigSets accepted Java jar and class files to be uploaded through the ConfigSets API. When backing up Solr Collections, these configSet files would be saved to disk when using the LocalFileSystemRepository (the default for backups). If the backup was saved to a directory that Solr uses in its ClassPath/ClassLoaders, then the jar and class files would be available to use with any ConfigSet, trusted or untrusted. When Solr is run in a secure way (Authorization enabled), as is strongly suggested, this vulnerability is limited to extending the Backup permissions with the ability to add libraries. Users are recommended to upgrade to version 8.11.3 or 9.4.1, which fix the issue. In these…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-37vr-vmg4-jwpw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-50386 Advisory: Apache Solr: Backup/Restore APIs allow for deployment of executables in malicious ConfigSets IDs: CVE-2023-50386, GHSA-37vr-vmg4-jwpw Record: https://patchnext.com/advisories/cve-2023-50386 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.solr:solr-core 9.4.1, 8.11.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.solr:solr-core: affected >= 6.0.0, < 8.11.3; >= 9.0.0, < 9.4.1; fixed in 8.11.3, 9.4.1 ## Suggested inspection (read-only) - Maven org.apache.solr:solr-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.solr:solr-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-37vr-vmg4-jwpw (GitHub-reviewed advisory GHSA-37vr-vmg4-jwpw lists affected ranges: Maven org.apache.solr:solr-core >=6.0.0 =9.0.0 <9.4.1) Commands are suggestions: review each one before running it.
Loading voting…