Skip to content

← Actionable
High, CVSS 7.5

Apache Solr can leak certain passwords due to System Property redaction logic inconsistencies

CVE-2023-50291GHSA-3hwc-rqwp-v36q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.solr:solr-core 9.3.0, 8.11.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-50291: 3.28% estimated exploitation activity in the next 30 days; percentile 88.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Insufficiently Protected Credentials vulnerability in Apache Solr. This issue affects Apache Solr from 6.0.0 through 8.11.2, from 9.0.0 before 9.3.0. One of the two endpoints that publishes the Solr process' Java system properties, /admin/info/properties, was only setup to hide system properties that had "password" contained in the name. There are a number of sensitive system properties, such as "basicauth" and "aws.secretKey" do not contain "password", thus their values were published via the "/admin/info/properties" endpoint. This endpoint populates the list of System Properties on the home screen of the Solr Admin page, making the exposed credentials visible in the UI. This /admin/info/properties endpoint is protected under the "config-read" permission. Therefore, Solr Clouds with Authorization enabled will only be vulnerable through logged-in users that have the "config-read" permission. Users are recommended to upgrade to version 9.3.0 or 8.11.3, both of which fix the issue. A…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3hwc-rqwp-v36q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-50291

Advisory: Apache Solr can leak certain passwords due to System Property redaction logic inconsistencies
IDs: CVE-2023-50291, GHSA-3hwc-rqwp-v36q
Record: https://patchnext.com/advisories/cve-2023-50291 (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.solr:solr-core 9.3.0, 8.11.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.solr:solr-core: affected >= 6.0.0, < 8.11.3; >= 9.0.0, < 9.3.0; fixed in 9.3.0, 8.11.3

## Suggested inspection (read-only)
- Maven org.apache.solr:solr-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.solr:solr-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3hwc-rqwp-v36q (GitHub-reviewed advisory GHSA-3hwc-rqwp-v36q lists affected ranges: Maven org.apache.solr:solr-core >=6.0.0 =9.0.0 <9.3.0)

Commands are suggestions: review each one before running it.

Loading voting…