Skip to content

← Actionable
Medium, CVSS 6.5

Apache Solr allows read access to host environmet variables

CVE-2023-50290GHSA-gg7w-pw2r-x2cq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.solr:solr-core 9.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-50290: 68.45% estimated exploitation activity in the next 30 days; percentile 99.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Solr. The Solr Metrics API publishes all unprotected environment variables available to each Apache Solr instance. Users are able to specify which environment variables to hide, however, the default list is designed to work for known secret Java system properties. Environment variables cannot be strictly defined in Solr, like Java system properties can be, and may be set for the entire host, unlike Java system properties which are set per-Java-proccess. The Solr Metrics API is protected by the "metrics-read" permission. Therefore, Solr Clouds with Authorization setup will only be vulnerable via users with the "metrics-read" permission. This issue affects Apache Solr: from 9.0.0 before 9.3.0. Users are recommended to upgrade to version 9.3.0 or later, in which environment variables are not published via the Metrics API.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gg7w-pw2r-x2cq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-50290

Advisory: Apache Solr allows read access to host environmet variables
IDs: CVE-2023-50290, GHSA-gg7w-pw2r-x2cq
Record: https://patchnext.com/advisories/cve-2023-50290 (revision 1, source checked 26 Oct 2026, 16:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.solr:solr-core 9.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.solr:solr-core: affected >= 9.0.0, < 9.3.0; fixed in 9.3.0

## Suggested inspection (read-only)
- Maven org.apache.solr:solr-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.solr:solr-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gg7w-pw2r-x2cq (GitHub-reviewed advisory GHSA-gg7w-pw2r-x2cq lists affected ranges: Maven org.apache.solr:solr-core >=9.0.0 <9.3.0)

Commands are suggestions: review each one before running it.

Loading voting…