Skip to content

← Actionable
Medium, CVSS 5.3

Denial of service caused by infinite recursion when parsing SVG document

CVE-2023-50251GHSA-ff5x-7qg5-vwf2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phenx/php-svg-lib 0.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2023-50251: 0.88% estimated exploitation activity in the next 30 days; percentile 59.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When parsing the attributes passed to a use tag inside an svg document, we can cause the system to go to an infinite recursion. Depending on the system configuration and attack pattern this could exhaust the memory available to the executing process and/or to the server itself. Details Inside Svg\Tag\UseTag::before, php-svg-lib parses the attributes passed to an use tag inside an svg document. When it finds a href or xlink:href, it will try to retrieve the object representing this tag: $document-getDef is implemented as follow: Note: the $id in the above method is actually the link being used in use tag. This part is important, because this behaviour here actually leads to the vulnerability. It will be mentioned later on in this report. If it finds the referenced object, it will try to call the before method on the referenced object (this is still inside Svg\Tag\UseTag::before) : In order to cause an infinte loop, we need to be able to control the $id used in the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-ff5x-7qg5-vwf2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-50251

Advisory: Denial of service caused by infinite recursion when parsing SVG document
IDs: CVE-2023-50251, GHSA-ff5x-7qg5-vwf2
Record: https://patchnext.com/advisories/cve-2023-50251 (revision 1, source checked 26 Oct 2026, 14:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phenx/php-svg-lib 0.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phenx/php-svg-lib: affected < 0.5.1; fixed in 0.5.1

## Suggested inspection (read-only)
- Packagist phenx/php-svg-lib: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phenx/php-svg-lib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ff5x-7qg5-vwf2 (GitHub-reviewed advisory GHSA-ff5x-7qg5-vwf2 lists affected ranges: Packagist phenx/php-svg-lib >=0 <0.5.1)

Commands are suggestions: review each one before running it.

Loading voting…