Skip to content

← Actionable
High, CVSS 7.5amended

Sentry's Astro SDK vulnerable to ReDoS

CVE-2023-50249GHSA-x3v3-8xg8-8v72

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sentry/astro 7.87.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-50249: 0.78% estimated exploitation activity in the next 30 days; percentile 56.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A ReDoS (Regular expression Denial of Service) vulnerability has been identified in Sentry's Astro SDK 7.78.0-7.86.0. Under certain conditions, this vulnerability allows an attacker to cause excessive computation times on the server, leading to denial of service (DoS). Applications that are using Sentry's Astro SDK are affected if: 1. They're using Sentry instrumentation: - they have manually registered Sentry Middleware (affected versions 7.78.0-7.86.0); - or configured Astro in SSR (server) or hybrid mode, use Astro 3.5.0 and newer and didn’t disable the automatic server instrumentation (affected versions 7.82.0-7.86.0). 2. They have configured routes with at least two path params (e.g. /foo/[p1]/bar/[p2]). Patches The problem has been patched in @sentry/astro@7.87.0. The corresponding PR: https://github.com/getsentry/sentry-javascript/pull/9815 Workarounds We strongly recommend upgrading to the latest SDK version. However, if it's not possible, the steps to mitigate the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x3v3-8xg8-8v72

  2. Revision 1 · created ·

    Published from osv record GHSA-x3v3-8xg8-8v72

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-50249

Advisory: Sentry's Astro SDK vulnerable to ReDoS
IDs: CVE-2023-50249, GHSA-x3v3-8xg8-8v72
Record: https://patchnext.com/advisories/cve-2023-50249 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @sentry/astro 7.87.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @sentry/astro: affected >= 7.78.0, < 7.87.0; fixed in 7.87.0

## Suggested inspection (read-only)
- `npm ls @sentry/astro --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @sentry/astro.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x3v3-8xg8-8v72 (OSV record GHSA-x3v3-8xg8-8v72 lists affected ranges: npm @sentry/astro >=7.78.0 <7.87.0 (fixed))
- Verified: https://github.com/advisories/GHSA-x3v3-8xg8-8v72 (GitHub-reviewed advisory GHSA-x3v3-8xg8-8v72 lists affected ranges: npm @sentry/astro >=7.78.0 <7.87.0)

Commands are suggestions: review each one before running it.

Loading voting…