Skip to content

← Actionable
Medium, CVSS 4.5amended

Out of memory error when submitting the dataset form with a specially-crafted field

CVE-2023-50248GHSA-7fgc-89cx-w8j5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckan 2.10.3, 2.9.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ckan

    Affected
    >= 2.0, < 2.9.10>= 2.10.0, < 2.10.3
    Fixed in
    2.10.3, 2.9.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-50248: 0.58% estimated exploitation activity in the next 30 days; percentile 47.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When submitting a POST request to the /dataset/new endpoint (including either the auth cookie or the Authorization header) with a specially-crafted field, an attacker can create an out-of-memory error in the hosting server. To trigger this error the user needs to have permissions to create or edit datasets. Patches This vulnerability has been patched in CKAN 2.10.3 and 2.9.10

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7fgc-89cx-w8j5

  2. Revision 1 · created ·

    Published from osv record GHSA-7fgc-89cx-w8j5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-50248

Advisory: Out of memory error when submitting the dataset form with a specially-crafted field
IDs: CVE-2023-50248, GHSA-7fgc-89cx-w8j5
Record: https://patchnext.com/advisories/cve-2023-50248 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ckan 2.10.3, 2.9.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ckan: affected >= 2.0, < 2.9.10; >= 2.10.0, < 2.10.3; fixed in 2.10.3, 2.9.10

## Suggested inspection (read-only)
- `python -m pip show ckan`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ckan.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7fgc-89cx-w8j5 (OSV record GHSA-7fgc-89cx-w8j5 lists affected ranges: PyPI ckan >=2.0 =2.10.0 <2.10.3 (fixed))
- Verified: https://github.com/advisories/GHSA-7fgc-89cx-w8j5 (GitHub-reviewed advisory GHSA-7fgc-89cx-w8j5 lists affected ranges: PyPI ckan >=2.0 =2.10.0 <2.10.3)

Commands are suggestions: review each one before running it.

Loading voting…