Password Change Vulnerability
CVE-2023-49804GHSA-88j4-pcx8-q4q3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (uptime-kuma 1.23.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm uptime-kuma
- Affected
- < 1.23.9
- Fixed in
- 1.23.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-88j4-pcx8-q4q3 lists affected ranges: npm uptime-kuma >=0 <1.23.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-88j4-pcx8-q4q3 lists affected ranges: npm uptime-kuma >=0 <1.23.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.7 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-49804: 0.26% estimated exploitation activity in the next 30 days; percentile 18.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview: A moderate security vulnerability has been identified in Uptime Kuma platform that poses a significant threat to the confidentiality and integrity of user accounts. When a user changes their login password in Uptime Kuma, a previously logged-in user retains access without being logged out. This behaviour persists consistently, even after system restarts or browser restarts. This vulnerability allows unauthorized access to user accounts, compromising the security of sensitive information. The same vulnerability was partially fixed in https://github.com/louislam/uptime-kuma/security/advisories/GHSA-g9v2-wqcj-j99g but logging existing users out of their accounts was forgotten. Impact: The impact of this vulnerability is moderate, as it enables attackers or unauthorized individuals to maintain access to user accounts even after the account password has been changed. This can lead to unauthorized data access, manipulation, or compromise of user accounts, posing a threat to the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-88j4-pcx8-q4q3
- Revision 1 · created ·
Published from osv record GHSA-88j4-pcx8-q4q3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-49804 Advisory: Password Change Vulnerability IDs: CVE-2023-49804, GHSA-88j4-pcx8-q4q3 Record: https://patchnext.com/advisories/cve-2023-49804 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: uptime-kuma 1.23.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm uptime-kuma: affected < 1.23.9; fixed in 1.23.9 ## Suggested inspection (read-only) - `npm ls uptime-kuma --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on uptime-kuma. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-88j4-pcx8-q4q3 (OSV record GHSA-88j4-pcx8-q4q3 lists affected ranges: npm uptime-kuma >=0 <1.23.9 (fixed)) - Verified: https://github.com/advisories/GHSA-88j4-pcx8-q4q3 (GitHub-reviewed advisory GHSA-88j4-pcx8-q4q3 lists affected ranges: npm uptime-kuma >=0 <1.23.9) Commands are suggestions: review each one before running it.
Loading voting…