Overly permissive origin policy
CVE-2023-49803GHSA-qxrj-hx23-xp82
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@koa/cors 5.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @koa/cors
- Affected
- < 5.0.0
- Fixed in
- 5.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qxrj-hx23-xp82 lists affected ranges: npm @koa/cors >=0 <5.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qxrj-hx23-xp82 lists affected ranges: npm @koa/cors >=0 <5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
- EPSS
- CVE-2023-49803: 0.28% estimated exploitation activity in the next 30 days; percentile 20.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Currently, the middleware operates in a way that if an allowed origin is not provided, it will return an Access-Control-Allow-Origin header with the value of the origin from the request. This behavior completely disables one of the most crucial elements of browsers - the Same Origin Policy (SOP), this could cause a very serious security threat to the users of this middleware. If such behavior is expected, for instance, when middleware is used exclusively for prototypes and not for production applications, it should be heavily emphasized in the documentation along with an indication of the risks associated with such behavior, as many users may not be aware of it.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qxrj-hx23-xp82
- Revision 1 · created ·
Published from osv record GHSA-qxrj-hx23-xp82
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-49803 Advisory: Overly permissive origin policy IDs: CVE-2023-49803, GHSA-qxrj-hx23-xp82 Record: https://patchnext.com/advisories/cve-2023-49803 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @koa/cors 5.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @koa/cors: affected < 5.0.0; fixed in 5.0.0 ## Suggested inspection (read-only) - `npm ls @koa/cors --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @koa/cors. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qxrj-hx23-xp82 (OSV record GHSA-qxrj-hx23-xp82 lists affected ranges: npm @koa/cors >=0 <5.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-qxrj-hx23-xp82 (GitHub-reviewed advisory GHSA-qxrj-hx23-xp82 lists affected ranges: npm @koa/cors >=0 <5.0.0) Commands are suggestions: review each one before running it.
Loading voting…