Skip to content

← Actionable
High, CVSS 7.5amended

DOS by abusing fetchOptions.retry.

CVE-2023-49800GHSA-q6hx-3m4p-749h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nuxt-api-party 0.22.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-49800: 0.80% estimated exploitation activity in the next 30 days; percentile 56.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary nuxt-api-party allows developers to proxy requests to an API without exposing credentials to the client. ofetch is used to send the requests. The library allows the user to send many options directly to ofetch. There is no filter on which options are available. We can abuse the retry logic to cause the server to crash from a stack overflow. Details fetchOptions are obtained directly from the request body. These are then passed directly into ofetch . We can construct a URL we know will not fetch successfully, then set the retry attempts to a high value, this will cause a stack overflow as ofetch error handling works recursively. PoC POC using Node. We can use proto as a substitute for the endpoint if it is not known. We can build the size of the stack faster by using more complicated URIs Impact Full DOS, server is unusable during attack. Requires a single request. Fix Limit which options can be passed to ofetch.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q6hx-3m4p-749h

  2. Revision 1 · created ·

    Published from osv record GHSA-q6hx-3m4p-749h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-49800

Advisory: DOS by abusing `fetchOptions.retry`.
IDs: CVE-2023-49800, GHSA-q6hx-3m4p-749h
Record: https://patchnext.com/advisories/cve-2023-49800 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nuxt-api-party 0.22.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nuxt-api-party: affected < 0.22.1; fixed in 0.22.1

## Suggested inspection (read-only)
- `npm ls nuxt-api-party --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nuxt-api-party.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q6hx-3m4p-749h (OSV record GHSA-q6hx-3m4p-749h lists affected ranges: npm nuxt-api-party >=0 <0.22.1 (fixed))
- Verified: https://github.com/advisories/GHSA-q6hx-3m4p-749h (GitHub-reviewed advisory GHSA-q6hx-3m4p-749h lists affected ranges: npm nuxt-api-party >=0 <0.22.1)

Commands are suggestions: review each one before running it.

Loading voting…