Skip to content

← Actionable
High, CVSS 7.5amended

SSRF & Credentials Leak

CVE-2023-49799GHSA-3wfp-253j-5jxv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nuxt-api-party 0.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-49799: 0.82% estimated exploitation activity in the next 30 days; percentile 57.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary nuxt-api-party allows developers to proxy requests to an API without exposing credentials to the client. A previous vulnerability allowed an attacker to change the baseURL of the request, potentially leading to credentials being leaked or SSRF. This vulnerability is similar, and was caused by a recent change to the detection of absolute URLs, which is no longer sufficient to prevent SSRF. Details nuxt-api-party attempts to check if the user has passed an absolute URL to prevent the aforementioned attack. This has been recently changed to use a regular expression ^https?://. This regular expression can be bypassed by an absolute URL with leading whitespace. For example \nhttps://whatever.com has a leading newline. According to the fetch specification, before a fetch is made the URL is normalized. "To normalize a byte sequence potentialValue, remove any leading and trailing HTTP whitespace bytes from potentialValue." (source) This means the final request will be normalized to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3wfp-253j-5jxv

  2. Revision 1 · created ·

    Published from osv record GHSA-3wfp-253j-5jxv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-49799

Advisory: SSRF & Credentials Leak
IDs: CVE-2023-49799, GHSA-3wfp-253j-5jxv
Record: https://patchnext.com/advisories/cve-2023-49799 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nuxt-api-party 0.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nuxt-api-party: affected < 0.22.0; fixed in 0.22.0

## Suggested inspection (read-only)
- `npm ls nuxt-api-party --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nuxt-api-party.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3wfp-253j-5jxv (OSV record GHSA-3wfp-253j-5jxv lists affected ranges: npm nuxt-api-party >=0 <0.22.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3wfp-253j-5jxv (GitHub-reviewed advisory GHSA-3wfp-253j-5jxv lists affected ranges: npm nuxt-api-party >=0 <0.22.0)

Commands are suggestions: review each one before running it.

Loading voting…