CodeChecker has a Path traversal in CodeChecker server in the endpoint of CodeChecker store
CVE-2023-49793GHSA-h26w-r4m5-8rrf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (codechecker 6.23.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI codechecker
- Affected
- < 6.23.0
- Fixed in
- 6.23.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h26w-r4m5-8rrf lists affected ranges: PyPI codechecker >=0 <6.23.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h26w-r4m5-8rrf lists affected ranges: PyPI codechecker >=0 <6.23.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-49793: 0.73% estimated exploitation activity in the next 30 days; percentile 54.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary ZIP files uploaded to the server-side endpoint handling a CodeChecker store are not properly sanitized. An attacker can exercise a path traversal to make the CodeChecker server load and display files from an arbitrary location on the server machine. Details Target The vulnerable endpoint is /<PRODUCTURL/v6.53/CodeCheckerService@massStoreRun. Exploit overview The attack is made possible by improper sanitization at one point in the process. 1. When the ZIP file is uploaded by CodeChecker store, it is first unzipped to a temporary directory (safely). 2. When deciding which files to insert into CodeChecker's internal database, the decision is made based on the contenthashes.json in the ZIP. An attacker has control over the contents of this file. 3. After reading that file, the paths specified in the JSON are normalized by this code: https://github.com/Ericsson/codechecker/blob/fa41e4e5d9566b5a4f5a80a27bddec73a5146f5a/web/server/codecheckerserver/api/massstorerun.py#L442-L444 4.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h26w-r4m5-8rrf
- Revision 1 · created ·
Published from osv record GHSA-h26w-r4m5-8rrf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-49793 Advisory: CodeChecker has a Path traversal in `CodeChecker server` in the endpoint of `CodeChecker store` IDs: CVE-2023-49793, GHSA-h26w-r4m5-8rrf Record: https://patchnext.com/advisories/cve-2023-49793 (revision 2, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: codechecker 6.23.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI codechecker: affected < 6.23.0; fixed in 6.23.0 ## Suggested inspection (read-only) - `python -m pip show codechecker`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on codechecker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h26w-r4m5-8rrf (OSV record GHSA-h26w-r4m5-8rrf lists affected ranges: PyPI codechecker >=0 <6.23.0 (fixed)) - Verified: https://github.com/advisories/GHSA-h26w-r4m5-8rrf (GitHub-reviewed advisory GHSA-h26w-r4m5-8rrf lists affected ranges: PyPI codechecker >=0 <6.23.0) Commands are suggestions: review each one before running it.
Loading voting…