No permission checks for editing/deleting records with CSV import form
CVE-2023-49783GHSA-j3m6-gvm8-mhvw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/admin 2.1.8, 1.13.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/admin
- Affected
- >= 1.0.0, < 1.13.19>= 2.0.0, < 2.1.8
- Fixed in
- 2.1.8, 1.13.19
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3m6-gvm8-mhvw lists affected ranges: Packagist silverstripe/admin >=1.0.0 =2.0.0 <2.1.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2023-49783: 0.34% estimated exploitation activity in the next 30 days; percentile 27.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users who don't have edit or delete permissions for records exposed in a ModelAdmin can still edit or delete records using the CSV import form, provided they have create permissions. The likelyhood of a user having create permissions but not having edit or delete permissions is low, but it is possible. Note that this doesn't affect any ModelAdmin which has had the import form disabled via the showImportForm public property, nor does it impact the SecurityAdmin section. Action may be required If you have a custom implementation of BulkLoader, you should update your implementation to respect permissions when the return value of getCheckPermissions() is true. If you are using any BulkLoader in your own project logic, or maintain a module which uses it, you should consider passing true to setCheckPermissions() if the data is provided by users. Base CVSS: 4.3 Reported by: Guy Sartorelli from Silverstripe References -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j3m6-gvm8-mhvw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-49783 Advisory: No permission checks for editing/deleting records with CSV import form IDs: CVE-2023-49783, GHSA-j3m6-gvm8-mhvw Record: https://patchnext.com/advisories/cve-2023-49783 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/admin 2.1.8, 1.13.19. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/admin: affected >= 1.0.0, < 1.13.19; >= 2.0.0, < 2.1.8; fixed in 2.1.8, 1.13.19 ## Suggested inspection (read-only) - Packagist silverstripe/admin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/admin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j3m6-gvm8-mhvw (GitHub-reviewed advisory GHSA-j3m6-gvm8-mhvw lists affected ranges: Packagist silverstripe/admin >=1.0.0 =2.0.0 <2.1.8) Commands are suggestions: review each one before running it.
Loading voting…