Skip to content

← Actionable
High, CVSS 7.3amended

NocoDB Vulnerable to Stored Cross-Site Scripting in Formula.vue

CVE-2023-49781GHSA-h6r4-xvw6-jc5h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nocodb 0.202.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm nocodb

    Affected
    <= 0.202.8
    Fixed in
    0.202.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2023-49781: 0.61% estimated exploitation activity in the next 30 days; percentile 49.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A stored cross-site scripting vulnerability exists within the Formula virtual cell comments functionality. Details The nc-gui/components/virtual-cell/Formula.vue displays a v-html tag with the value of "urls" whose contents are processed by the function replaceUrlsWithLink(). This function recognizes the pattern URI::(XXX) and creates a hyperlink tag <a with href=XXX. However, it leaves all the other contents outside of the pattern URI::(XXX) unchanged, which makes the evil users can create a malicious table with a formula field whose payload is <img src=1 onerror="malicious javascripts"URI::(XXX). The evil users then can share this table with others by enabling public viewing and the victims who open the shared link can be attacked. PoC Step 1: Attacker login the nocodb and creates a table with two fields, "T" and "F". The type of field "T" is "SingleLineText", and the type of the "F" is "Fomula" with the formula content {T} Step 2: The attacker sets the contents of T using…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h6r4-xvw6-jc5h

  2. Revision 1 · created ·

    Published from osv record GHSA-h6r4-xvw6-jc5h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-49781

Advisory: NocoDB Vulnerable to Stored Cross-Site Scripting in Formula.vue
IDs: CVE-2023-49781, GHSA-h6r4-xvw6-jc5h
Record: https://patchnext.com/advisories/cve-2023-49781 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nocodb 0.202.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nocodb: affected <= 0.202.8; fixed in 0.202.9

## Suggested inspection (read-only)
- `npm ls nocodb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nocodb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h6r4-xvw6-jc5h (OSV record GHSA-h6r4-xvw6-jc5h lists affected ranges: npm nocodb >=0 <0.202.9 (fixed))
- Verified: https://github.com/advisories/GHSA-h6r4-xvw6-jc5h (GitHub-reviewed advisory GHSA-h6r4-xvw6-jc5h lists affected ranges: npm nocodb >=0 <=0.202.8)

Commands are suggestions: review each one before running it.

Loading voting…