Cross-site Scripting in Apache superset
CVE-2023-49657GHSA-rwhh-6x83-84v6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-superset 3.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-superset
- Affected
- < 3.0.3
- Fixed in
- 3.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rwhh-6x83-84v6 lists affected ranges: PyPI apache-superset >=0 <3.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rwhh-6x83-84v6 lists affected ranges: PyPI apache-superset >=0 <3.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2023-49657: 0.84% estimated exploitation activity in the next 30 days; percentile 57.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A stored cross-site scripting (XSS) vulnerability exists in Apache Superset before 3.0.3. An authenticated attacker with create/update permissions on charts or dashboards could store a script or add a specific HTML snippet that would act as a stored XSS. For 2.X versions, users should change their config to include: TALISMAN_CONFIG = { "content_security_policy": { "base-uri": ["'self'"], "default-src": ["'self'"], "img-src": ["'self'", "blob:", "data:"], "worker-src": ["'self'", "blob:"], "connect-src": [ "'self'", " https://api.mapbox.com" https://api.mapbox.com" ;, " https://events.mapbox.com" https://events.mapbox.com" ;, ], "object-src": "'none'", "style-src": [ "'self'", "'unsafe-inline'", ], "script-src": ["'self'", "'strict-dynamic'"], }, "content_security_policy_nonce_in": ["script-src"], "force_https": False, "session_cookie_secure": False, }
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-rwhh-6x83-84v6
- Revision 3 · amended ·
Amended from ghsa record GHSA-rwhh-6x83-84v6
- Revision 2 · amended ·
Amended from ghsa record GHSA-rwhh-6x83-84v6
- Revision 1 · created ·
Published from osv record GHSA-rwhh-6x83-84v6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-49657 Advisory: Cross-site Scripting in Apache superset IDs: CVE-2023-49657, GHSA-rwhh-6x83-84v6 Record: https://patchnext.com/advisories/cve-2023-49657 (revision 4, source checked 28 Oct 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-superset 3.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-superset: affected < 3.0.3; fixed in 3.0.3 ## Suggested inspection (read-only) - `python -m pip show apache-superset`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-superset. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rwhh-6x83-84v6 (OSV record GHSA-rwhh-6x83-84v6 lists affected ranges: PyPI apache-superset >=0 <3.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-rwhh-6x83-84v6 (GitHub-reviewed advisory GHSA-rwhh-6x83-84v6 lists affected ranges: PyPI apache-superset >=0 <3.0.3) Commands are suggestions: review each one before running it.
Loading voting…