Open redirect vulnerability in Flask-Security-Too
CVE-2023-49438GHSA-672h-6x89-76m5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-security-too 5.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI flask-security-too
- Affected
- < 5.3.3
- Fixed in
- 5.3.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-672h-6x89-76m5 lists affected ranges: PyPI flask-security-too >=0 <5.3.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-672h-6x89-76m5 lists affected ranges: PyPI flask-security-too >=0 <5.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2023-49438: 1.08% estimated exploitation activity in the next 30 days; percentile 65.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows attackers to redirect unsuspecting users to malicious sites via a crafted URL by abusing the ?next parameter on the /login and /register routes. Flask-Security-Too contains logic to validate that the URL specified within the next parameter is either relative or has the same network location as the requesting URL in an attempt to prevent open redirections. Previously known examples that bypassed the validation logic such as https://example/login?next=\\\\\\github.com were patched in version 4.1.0 However, examples such as https://example/login?next=/\\github.com and https://example/login?next=\\/github.com were discovered due to how web browsers normalize slashes in URLs, which makes the package vulnerable through version <=5.3.2 Additionally, with Werkzeug =2.1.0 the autocorrectlocationheader configuration was changed to False - which means that location headers in redirects are relative by…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-672h-6x89-76m5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-672h-6x89-76m5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-49438 Advisory: Open redirect vulnerability in Flask-Security-Too IDs: CVE-2023-49438, GHSA-672h-6x89-76m5 Record: https://patchnext.com/advisories/cve-2023-49438 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flask-security-too 5.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI flask-security-too: affected < 5.3.3; fixed in 5.3.3 ## Suggested inspection (read-only) - `python -m pip show flask-security-too`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flask-security-too. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-672h-6x89-76m5 (OSV record GHSA-672h-6x89-76m5 lists affected ranges: PyPI flask-security-too >=0 <5.3.3 (fixed)) - Verified: https://github.com/advisories/GHSA-672h-6x89-76m5 (GitHub-reviewed advisory GHSA-672h-6x89-76m5 lists affected ranges: PyPI flask-security-too >=0 <5.3.3) Commands are suggestions: review each one before running it.
Loading voting…