Phpseclib needs guardrails on large binaryfield integers
CVE-2023-49316GHSA-2f25-pfq3-c7h8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpseclib/phpseclib 3.0.34), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpseclib/phpseclib
- Affected
- >= 3.0.0, < 3.0.34
- Fixed in
- 3.0.34
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2f25-pfq3-c7h8 lists affected ranges: Packagist phpseclib/phpseclib >=3.0.0 <3.0.34
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-49316: 0.78% estimated exploitation activity in the next 30 days; percentile 56.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc) Patches https://github.com/phpseclib/phpseclib/commit/964d78101a70305df33f442f5490f0adb3b7e77f Workarounds No. References https://github.com/phpseclib/phpseclib/commit/964d78101a70305df33f442f5490f0adb3b7e77f https://www.usenix.org/system/files/usenixsecurity25-shi-bing.pdf
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2f25-pfq3-c7h8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-49316 Advisory: Phpseclib needs guardrails on large binaryfield integers IDs: CVE-2023-49316, GHSA-2f25-pfq3-c7h8 Record: https://patchnext.com/advisories/cve-2023-49316 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpseclib/phpseclib 3.0.34. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpseclib/phpseclib: affected >= 3.0.0, < 3.0.34; fixed in 3.0.34 ## Suggested inspection (read-only) - Packagist phpseclib/phpseclib: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpseclib/phpseclib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2f25-pfq3-c7h8 (GitHub-reviewed advisory GHSA-2f25-pfq3-c7h8 lists affected ranges: Packagist phpseclib/phpseclib >=3.0.0 <3.0.34) Commands are suggestions: review each one before running it.
Loading voting…