PyDrive2's unsafe YAML deserialization in LoadSettingsFile allows arbitrary code execution
CVE-2023-49297GHSA-v5f6-hjmf-9mc5
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pydrive2
- Affected
- >= 1.17.0, <= 1.17.0< 1.16.2
- Fixed in
- 1.16.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v5f6-hjmf-9mc5 lists affected ranges: PyPI pydrive2 >=1.17.0 =0 <1.16.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v5f6-hjmf-9mc5 lists affected ranges: PyPI pydrive2 >=1.17.0 =0 <1.16.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.3 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-49297: 0.51% estimated exploitation activity in the next 30 days; percentile 43.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Unsafe YAML deserilization will result in arbitrary code execution. A maliciously crafted YAML file can cause arbitrary code execution if PyDrive2 is run in the same directory as it, or if it is loaded in via LoadSettingsFile. Details The loader being imported from the yaml library is CLoader: https://github.com/iterative/PyDrive2/blob/30c0f487c0666c0d1944ef774107359f39adc2fa/pydrive2/settings.py#L5 This loader is then used to load a user supplied file: https://github.com/iterative/PyDrive2/blob/30c0f487c0666c0d1944ef774107359f39adc2fa/pydrive2/settings.py#L108-L121 CLoader is considered unsafe. It will allow any Python code inside of it to be executed. This loading behaviour also happens automatically, the file only needs to be present for this vulnerability to occur. https://github.com/iterative/PyDrive2/blob/30c0f487c0666c0d1944ef774107359f39adc2fa/pydrive2/settings.py#L9 Reference: https://www.exploit-db.com/docs/english/47655-yaml-deserialization-attack-in-python.pdf PoC…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v5f6-hjmf-9mc5
- Revision 1 · created ·
Published from osv record GHSA-v5f6-hjmf-9mc5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-49297 Advisory: PyDrive2's unsafe YAML deserialization in LoadSettingsFile allows arbitrary code execution IDs: CVE-2023-49297, GHSA-v5f6-hjmf-9mc5 Record: https://patchnext.com/advisories/cve-2023-49297 (revision 2, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: pydrive2 1.16.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pydrive2: affected >= 1.17.0, <= 1.17.0; < 1.16.2; fixed in 1.16.2 ## Suggested inspection (read-only) - `python -m pip show pydrive2`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pydrive2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v5f6-hjmf-9mc5 (OSV record GHSA-v5f6-hjmf-9mc5 lists affected ranges: PyPI pydrive2 >=1.17.0 =0 <1.16.2 (fixed)) - Verified: https://github.com/advisories/GHSA-v5f6-hjmf-9mc5 (GitHub-reviewed advisory GHSA-v5f6-hjmf-9mc5 lists affected ranges: PyPI pydrive2 >=1.17.0 =0 <1.16.2) Commands are suggestions: review each one before running it.
Loading voting…