Skip to content

← Actionable
Medium, CVSS 6.1amended

Reflected XSS Vulnerability in dpaste

CVE-2023-49277GHSA-r8j9-5cj7-cv39

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dpaste 3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI dpaste

    Affected
    < 3.8
    Fixed in
    3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-49277: 0.52% estimated exploitation activity in the next 30 days; percentile 44.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A security vulnerability has been identified in the expires parameter of the dpaste API, allowing for a POST Reflected XSS attack. This vulnerability can be exploited by an attacker to execute arbitrary JavaScript code in the context of a user's browser, potentially leading to unauthorized access, data theft, or other malicious activities. Patches - A patch has been applied to the dpaste GitHub repository to address the specific content value injection vulnerability. - Users are strongly advised to upgrade to dpaste release v3.8 or later versions, as dpaste versions older than v3.8 are susceptible to the identified security vulnerability. - The patch can be viewed and applied from the following link: dpaste Commit Patch Workarounds At this time, the recommended course of action is to apply the provided patch to the affected systems. No known workarounds have been identified, and applying the patch is the most effective way to remediate the vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r8j9-5cj7-cv39

  2. Revision 1 · created ·

    Published from osv record GHSA-r8j9-5cj7-cv39

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-49277

Advisory: Reflected XSS Vulnerability in dpaste
IDs: CVE-2023-49277, GHSA-r8j9-5cj7-cv39
Record: https://patchnext.com/advisories/cve-2023-49277 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dpaste 3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI dpaste: affected < 3.8; fixed in 3.8

## Suggested inspection (read-only)
- `python -m pip show dpaste`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dpaste.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r8j9-5cj7-cv39 (OSV record GHSA-r8j9-5cj7-cv39 lists affected ranges: PyPI dpaste >=0 <3.8 (fixed))
- Verified: https://github.com/advisories/GHSA-r8j9-5cj7-cv39 (GitHub-reviewed advisory GHSA-r8j9-5cj7-cv39 lists affected ranges: PyPI dpaste >=0 <3.8)

Commands are suggestions: review each one before running it.

Loading voting…