Skip to content

← Actionable
Medium, CVSS 6.1amended

Attribute Injection leading to XSS(Cross-Site-Scripting)

CVE-2023-49276GHSA-v4v2-8h88-65qj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uptime-kuma 1.23.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm uptime-kuma

    Affected
    >= 1.20.0, <= 1.23.6
    Fixed in
    1.23.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-49276: 0.50% estimated exploitation activity in the next 30 days; percentile 42.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Google Analytics element Attribute Injection leading to XSS Details Since the custom status interface can set an independent Google Analytics ID and the template has not been sanitized, there is an attribute injection vulnerability here, which can lead to XSS attacks. PoC 1. Run the latest version of the louislam/uptime-kuma container and initialize the account password. 2. Create a new status page. 3. Edit the status page and change the Google Analytics ID to following payload(it only works for firefox. Any attribute can be injected, but this seems the most intuitive): 4. Click Save and return to the interface. XSS occurs. screenshots:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v4v2-8h88-65qj

  2. Revision 1 · created ·

    Published from osv record GHSA-v4v2-8h88-65qj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-49276

Advisory: Attribute Injection leading to XSS(Cross-Site-Scripting)
IDs: CVE-2023-49276, GHSA-v4v2-8h88-65qj
Record: https://patchnext.com/advisories/cve-2023-49276 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uptime-kuma 1.23.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm uptime-kuma: affected >= 1.20.0, <= 1.23.6; fixed in 1.23.7

## Suggested inspection (read-only)
- `npm ls uptime-kuma --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uptime-kuma.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v4v2-8h88-65qj (OSV record GHSA-v4v2-8h88-65qj lists affected ranges: npm uptime-kuma >=1.20.0 <1.23.7 (fixed))
- Verified: https://github.com/advisories/GHSA-v4v2-8h88-65qj (GitHub-reviewed advisory GHSA-v4v2-8h88-65qj lists affected ranges: npm uptime-kuma >=1.20.0 <=1.23.6)

Commands are suggestions: review each one before running it.

Loading voting…