Skip to content

← Actionable
Low, CVSS 3.7

SMTP misconfiguration leading to "Forgot Password" exploit that leaks registered user email.

CVE-2023-49274GHSA-8qp8-9rpw-j46c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (umbraco.cms 12.3.4, 10.8.1, 8.18.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet umbraco.cms

    Affected
    >= 8.0.0, < 8.18.10>= 9.0.0, < 10.8.1>= 11.0.0, < 12.3.4
    Fixed in
    12.3.4, 10.8.1, 8.18.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2023-49274: 0.46% estimated exploitation activity in the next 30 days; percentile 39.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A user enumeration attack is possible when SMTP is not setup correctly, but reset password is enabled Explanation of the vulnerability Two different error messages was shown, based on if the user exists or not when using the forgot password functionality, when the SMTP was configured but do not response.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8qp8-9rpw-j46c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-49274

Advisory: SMTP misconfiguration leading to "Forgot Password" exploit that leaks registered user email.
IDs: CVE-2023-49274, GHSA-8qp8-9rpw-j46c
Record: https://patchnext.com/advisories/cve-2023-49274 (revision 1, source checked 26 Oct 2026, 17:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: umbraco.cms 12.3.4, 10.8.1, 8.18.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet umbraco.cms: affected >= 8.0.0, < 8.18.10; >= 9.0.0, < 10.8.1; >= 11.0.0, < 12.3.4; fixed in 12.3.4, 10.8.1, 8.18.10

## Suggested inspection (read-only)
- NuGet umbraco.cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on umbraco.cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8qp8-9rpw-j46c (GitHub-reviewed advisory GHSA-8qp8-9rpw-j46c lists affected ranges: NuGet umbraco.cms >=8.0.0 =9.0.0 =11.0.0 <12.3.4)

Commands are suggestions: review each one before running it.

Loading voting…