Skip to content

← Actionable
High, CVSS 8.8

Keycloak vulnerable to Plaintext Storage of User Password

CVE-2023-4918GHSA-5q66-v53q-pm35

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-core 22.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-4918: 0.57% estimated exploitation activity in the next 30 days; percentile 47.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was discovered in Keycloak Core package. When a user registers itself through registration flow, the "password" and "password-confirm" field from the form will occur as regular attributes in the users attributes. The password is also created, but the user attributes must not be there. This way, any entities (all users and clients with proper rights/roles) are able to retrieve the users passwords in clear-text. Impact Passwords for self-registered users are stored as cleartext attributes associated with the user. Mitigation Disable self-registration for users in all realms until patched.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5q66-v53q-pm35

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-4918

Advisory: Keycloak vulnerable to Plaintext Storage of User Password
IDs: CVE-2023-4918, GHSA-5q66-v53q-pm35
Record: https://patchnext.com/advisories/cve-2023-4918 (revision 1, source checked 26 Oct 2026, 16:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-core 22.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.keycloak:keycloak-core: affected >= 22.0.2, <= 22.0.2; fixed in 22.0.3

## Suggested inspection (read-only)
- Maven org.keycloak:keycloak-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.keycloak:keycloak-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5q66-v53q-pm35 (GitHub-reviewed advisory GHSA-5q66-v53q-pm35 lists affected ranges: Maven org.keycloak:keycloak-core >=22.0.2 <=22.0.2)

Commands are suggestions: review each one before running it.

Loading voting…