Skip to content

← Actionable
Medium, CVSS 5.9amended

cryptography vulnerable to NULL-dereference when loading PKCS7 certificates

CVE-2023-49083GHSA-jfhm-5ghh-2f97

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cryptography 41.0.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-49083: 0.98% estimated exploitation activity in the next 30 days; percentile 62.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Calling loadpempkcs7certificates or loadderpkcs7certificates could lead to a NULL-pointer dereference and segfault. PoC Here is a Python code that triggers the issue: Impact Exploitation of this vulnerability poses a serious risk of Denial of Service (DoS) for any application attempting to deserialize a PKCS7 blob/certificate. The consequences extend to potential disruptions in system availability and stability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jfhm-5ghh-2f97

  2. Revision 1 · created ·

    Published from osv record GHSA-jfhm-5ghh-2f97

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-49083

Advisory: cryptography vulnerable to NULL-dereference when loading PKCS7 certificates
IDs: CVE-2023-49083, GHSA-jfhm-5ghh-2f97
Record: https://patchnext.com/advisories/cve-2023-49083 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cryptography 41.0.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI cryptography: affected >= 3.1, < 41.0.6; fixed in 41.0.6

## Suggested inspection (read-only)
- `python -m pip show cryptography`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cryptography.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jfhm-5ghh-2f97 (OSV record GHSA-jfhm-5ghh-2f97 lists affected ranges: PyPI cryptography >=3.1 <41.0.6 (fixed))
- Verified: https://github.com/advisories/GHSA-jfhm-5ghh-2f97 (GitHub-reviewed advisory GHSA-jfhm-5ghh-2f97 lists affected ranges: PyPI cryptography >=3.1 <41.0.6)

Commands are suggestions: review each one before running it.

Loading voting…