aiohttp's ClientSession is vulnerable to CRLF injection via method
CVE-2023-49082GHSA-qvrw-v9rv-5rjx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (aiohttp 3.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI aiohttp
- Affected
- < 3.9.0
- Fixed in
- 3.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qvrw-v9rv-5rjx lists affected ranges: PyPI aiohttp >=0 <3.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qvrw-v9rv-5rjx lists affected ranges: PyPI aiohttp >=0 <3.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-49082: 0.95% estimated exploitation activity in the next 30 days; percentile 61.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Improper validation makes it possible for an attacker to modify the HTTP request (e.g. insert a new header) or even create a new HTTP request if the attacker controls the HTTP method. Details The vulnerability occurs only if the attacker can control the HTTP method (GET, POST etc.) of the request. Previous releases performed no validation on the provided value. If an attacker controls the HTTP method it will be used as is and can lead to HTTP request smuggling. PoC A minimal example can be found here: https://gist.github.com/jnovikov/7f411ae9fe6a9a7804cf162a3bdbb44b Impact If the attacker can control the HTTP version of the request it will be able to modify the request (request smuggling). Workaround If unable to upgrade and using user-provided values for the request method, perform manual validation of the user value (e.g. by restricting it to a few known values like GET, POST etc.). Patch: https://github.com/aio-libs/aiohttp/pull/7806/files
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qvrw-v9rv-5rjx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-qvrw-v9rv-5rjx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-49082 Advisory: aiohttp's ClientSession is vulnerable to CRLF injection via method IDs: CVE-2023-49082, GHSA-qvrw-v9rv-5rjx Record: https://patchnext.com/advisories/cve-2023-49082 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: aiohttp 3.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI aiohttp: affected < 3.9.0; fixed in 3.9.0 ## Suggested inspection (read-only) - `python -m pip show aiohttp`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on aiohttp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qvrw-v9rv-5rjx (OSV record GHSA-qvrw-v9rv-5rjx lists affected ranges: PyPI aiohttp >=0 <3.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-qvrw-v9rv-5rjx (GitHub-reviewed advisory GHSA-qvrw-v9rv-5rjx lists affected ranges: PyPI aiohttp >=0 <3.9.0) Commands are suggestions: review each one before running it.
Loading voting…