jupyter-server errors include tracebacks with path information
CVE-2023-49080GHSA-h56g-gq9v-vc8r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server 2.11.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-server
- Affected
- < 2.11.2
- Fixed in
- 2.11.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h56g-gq9v-vc8r lists affected ranges: PyPI jupyter-server >=0 <2.11.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h56g-gq9v-vc8r lists affected ranges: PyPI jupyter-server >=0 <2.11.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-49080: 0.84% estimated exploitation activity in the next 30 days; percentile 57.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Unhandled errors in API requests include traceback information, which can include path information. There is no known mechanism by which to trigger these errors without authentication, so the paths revealed are not considered particularly sensitive, given that the requesting user has arbitrary execution permissions already in the same environment. Patches jupyter-server PATCHEDVERSION no longer includes traceback information in JSON error responses. For compatibility, the traceback field is present, but always empty. Workarounds None
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h56g-gq9v-vc8r
- Revision 1 · created ·
Published from osv record GHSA-h56g-gq9v-vc8r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-49080 Advisory: jupyter-server errors include tracebacks with path information IDs: CVE-2023-49080, GHSA-h56g-gq9v-vc8r Record: https://patchnext.com/advisories/cve-2023-49080 (revision 2, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-server 2.11.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-server: affected < 2.11.2; fixed in 2.11.2 ## Suggested inspection (read-only) - `python -m pip show jupyter-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h56g-gq9v-vc8r (OSV record GHSA-h56g-gq9v-vc8r lists affected ranges: PyPI jupyter-server >=0 <2.11.2 (fixed)) - Verified: https://github.com/advisories/GHSA-h56g-gq9v-vc8r (GitHub-reviewed advisory GHSA-h56g-gq9v-vc8r lists affected ranges: PyPI jupyter-server >=0 <2.11.2) Commands are suggestions: review each one before running it.
Loading voting…