Phpsysinfo Cross Site Request Forgery (CSRF) vulnerability
CVE-2023-49006GHSA-67gv-xrw7-p72w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpsysinfo/phpsysinfo 3.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpsysinfo/phpsysinfo
- Affected
- < 3.4.3
- Fixed in
- 3.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-67gv-xrw7-p72w lists affected ranges: Packagist phpsysinfo/phpsysinfo >=0 <3.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-49006: 0.52% estimated exploitation activity in the next 30 days; percentile 44.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross Site Request Forgery (CSRF) vulnerability in Phpsysinfo version 3.4.3 allows a remote attacker to obtain sensitive information via a crafted page in the XML.php file. Phpsysinfo 3.4.3 disables the functionality by default but the users may enable the vulnerable functionality.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-67gv-xrw7-p72w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-49006 Advisory: Phpsysinfo Cross Site Request Forgery (CSRF) vulnerability IDs: CVE-2023-49006, GHSA-67gv-xrw7-p72w Record: https://patchnext.com/advisories/cve-2023-49006 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpsysinfo/phpsysinfo 3.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpsysinfo/phpsysinfo: affected < 3.4.3; fixed in 3.4.3 ## Suggested inspection (read-only) - Packagist phpsysinfo/phpsysinfo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpsysinfo/phpsysinfo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-67gv-xrw7-p72w (GitHub-reviewed advisory GHSA-67gv-xrw7-p72w lists affected ranges: Packagist phpsysinfo/phpsysinfo >=0 <3.4.3) Commands are suggestions: review each one before running it.
Loading voting…